Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36865

Stage view showing wrong pipeline data

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After running a few pipeline executions, if you delete the job and recreate it will show the proper pipeline while building, but after the pipeline has completed running it will revert to showing the pipeline from the previous (deleted) run. After looking at the code to the plugin, I was able to determine that there was a cache and found some code in the tests to invalidate it.

      I was able to workaround the issue by running the following code in the script console:

      import com.cloudbees.workflow.flownode.FlowNodeUtil
      
      FlowNodeUtil.CacheExtension ext = FlowNodeUtil.CacheExtension.all().get(0);
      ext.getExecutionCache().invalidateAll();
      ext.getRunCache().invalidateAll();
      

        Attachments

          Activity

          antoniobeyah Antonio Beyah created issue -
          antoniobeyah Antonio Beyah made changes -
          Field Original Value New Value
          Description After running a few pipeline executions, if you delete the job and recreate it will show the proper pipeline while building, but after the pipeline has completed running it will revert to showing the pipeline from the previous (deleted) run. After looking at the code to the plugin, I was able to determine that there was a cache and found some code in the tests to invalidate it.

          I was able to workaround the issue by running the following code in the script console:

          {code:groovy}
          import com.cloudbees.workflow.flownode.FlowNodeUtil

          FlowNodeUtil.CacheExtension ext = FlowNodeUtil.CacheExtension.all().get(0);
          ext.getExecutionCache().invalidateAll();
          ext.getRunCache().invalidateAll();
          {code}
          After running a few pipeline executions, if you delete the job and recreate it will show the proper pipeline while building, but after the pipeline has completed running it will revert to showing the pipeline from the previous (deleted) run. After looking at the code to the plugin, I was able to determine that there was a cache and found some code in the tests to invalidate it.

          I was able to workaround the issue by running the following code in the script console:

          {code:java}
          import com.cloudbees.workflow.flownode.FlowNodeUtil

          FlowNodeUtil.CacheExtension ext = FlowNodeUtil.CacheExtension.all().get(0);
          ext.getExecutionCache().invalidateAll();
          ext.getRunCache().invalidateAll();
          {code}
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 173612 ] JNJira + In-Review [ 185231 ]
          svanoort Sam Van Oort made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          svanoort Sam Van Oort made changes -
          Status In Progress [ 3 ] In Review [ 10005 ]
          svanoort Sam Van Oort made changes -
          Status In Review [ 10005 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]

            People

            • Assignee:
              svanoort Sam Van Oort
              Reporter:
              antoniobeyah Antonio Beyah
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: