Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36989

Unnecessary CMake auto-download fails and breaks build after upgrade to jenkins2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: cmakebuilder-plugin
    • Labels:
      None
    • Environment:
      Master running on linux (docker, jenkins 2.7.1)
      Slave running on Windows Server 2012R2
      CMake plugin 2.4.3
    • Similar Issues:

      Description

      I did a test upgrade for my server from jenkins 1.651.2 to 2.7.1. The slaves are auto-connecting swarm slaves, their configuration hasn't changed.

      After upgrading, all cmake build projects fail with the following:

      ERROR: Install from cmake.org [CMake 3.4.1]: No cmake download known for OS `Windows Server 2012 R2` and arch `amd64`.

      I believe this shouldn't happen, for the following reasons:

      Any idea what might be going wrong or how to fix this would be appreciated.

        Attachments

          Activity

          15knots Martin Weber added a comment - - edited

          I just tested to migrate to Jenkins 2.7.1 and cannot reproduce it.

          Cmake gets downloaded and installed to

          $JENKINS_HOME/tools/hudson.plugins.cmake.CmakeTool/3.4.1/
          

          on the slave. That location did not change in 2.7.1, so something must have deleted it, causing the new download.

          Maybe file

          $JENKINS_HOME/updates/hudson.plugins.cmake.CmakeInstaller
          

          (on the master) is corrupted and makes the download fail? It should contain the text "https://cmake.org/files/v3.4/cmake-3.4.1-win32-x86.zip".

          What does the Jenkins log say?

          jorgziegler Jörg Ziegler added a comment -

          thanks a bunch for the quick feedback. It was indeed so that the $JENKINS_HOME/updates/ folder had been incorrectly backed up and hence the CmakeInstaller file was not corrupt but in fact missing, which in turn caused the error message.

          Supplying the file at the right location fixes the problem.

          Thanks again for being so very reactive.


            People

            • Assignee:
              Unassigned
              Reporter:
              jorgziegler Jörg Ziegler
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: