Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I have heard new users complain about Hudson that they were confused just
      looking at the main screen because they didn't know what a blue ball meant. Red
      is clearly failure, but blue is not absolutely clear. Every other tool which
      displays the results of tests uses green to mean success. Hudson should do the same.

        Attachments

          Issue Links

            Activity

            kohsuke Kohsuke Kawaguchi added a comment -

            Blue is one of the main color palette that Hudson uses, so replacing that with
            green would need other color adjustments (such as the banner, test report
            charts, etc.) Color is a part of the branding, so I takes certain courage to
            make this change.

            I really wish we could get a real designer to work on the UI.

            Personally, I've never heard this complaint from any of the users in the list or
            in person. Is it a common complaint among your team?

            troggan troggan added a comment -

            Everyone in my Team had this problem. Blue is not a good colour for a
            successfull build from a usability perspective.

            And I don't think you have to change every colour in your Gui because of that.
            Simply change the blue Icons to green ones. You already have green Icons in the
            Gui ("Back to Dashboard"). Look into the colour set for the tango icon set and
            you will find a nice green.

            jglick Jesse Glick added a comment -

            I think I've just heard it brought up once from my team. (Came up at the same
            time as #370.) But not sure.

            jglick Jesse Glick added a comment -
                • Issue 572 has been marked as a duplicate of this issue. ***
            kohsuke Kohsuke Kawaguchi added a comment -

            This thread http://www.nabble.com/status-bullet-color-tf4323528.html includes
            some interesting points.

            kohsuke Kohsuke Kawaguchi added a comment -

            Another recurrence of this issue in the users list. This time, several people
            who are fine with blue chimed in.

            http://www.nabble.com/hudson-job-status-icons-tf4887248.html

            I guess for this issue to make progress, we really need an artist who could
            create appropriate icons.

            troggan troggan added a comment -

            Simply post a request in the tango mailinglist. Your icons are tango icons, am I
            right?

            kohsuke Kohsuke Kawaguchi added a comment -

            Here's what it takes to fix this issue:

            1. Prepare the ball icons in green. This involves in tweaking svg at
            hudson/main/war/images. Start by copying blue.svg, and use tango color palette
            <http://tango.freedesktop.org/Tango_Icon_Theme_Guidelines>.

            2. running make.sh would regenerate all the necessary png/gif files. It might be
            hard for other folks to run this script, so I'd be willing to do this.

            3. Use new green orb instead of blue orb, and see how the screen looks. Notice
            that Hudson uses the blue theme extensively elsewhere, such as in hyperlinks,
            caption bar, and progress bar, and test results. Think hard if we need to
            convert them to green, too, or if it's not necessary. Probably a mock up is
            necessary to do a fair comparison.

            4. if the other colors need to be modified, edit CSS in
            hudson/war/resources/css/*.css and other image files in
            hudson/war/resources/images/*.png

            stephenconnolly stephenconnolly added a comment -

            I am -1000 on fixing this issue.

            To make me +1 we need to have the theme plugable. I like blue, my team likes
            blue, our VP likes blue. let it be a system setting to pick the theme.

            If you are just doing a straight replace without making it plugable I think that
            is a big mistake

            mdonohue mdonohue added a comment -

            It's hard to call a personal preference a 'defect' so I'm changing this to an
            enhancement. Based on Stephen's comment, it seems this should be generalized
            into a 'pluggable themes' enhancement, instead of discussing the specifics of
            blue vs green.

            kohsuke Kohsuke Kawaguchi added a comment -

            One more reccurrence of this topic in the users list:
            http://www.nabble.com/Blue-for-success-to18742354.html#a18742354

            In particular, see http://groups.yahoo.com/group/ParthenonWeekly/message/232
            ------------------------------
            Q. "Why do Japanese people say that they have blue traffic lights
            when they are really green?"--Question submitted by John Sypal

            A. According to the book, Japan From A to Z: Mysteries of Everyday
            Life Explained by James and Michiko Vardaman, the first traffic
            signals in Japan were blue instead of green, but the blue lights were
            difficult to see from a long distance away so they were replaced with
            green ones. Vardaman says that the custom of referring to traffic
            lights is a holdover from those days.
            This sounds like a good explanation, but the problem with it is that
            you will hear Japanese people refer to other green things (like
            cucumbers, spinach, and sometimes grass) as being blue as well. This
            is because historically, Japanese people considered green to be a
            shade of blue. For example, the Chinese character for blue,
            pronounced ao is made up of two characters, iki (life) and i (well)
            and refers to the colour of plants which grow around a well, a colour
            between green and blue. When Chinese people see the character, they
            say it means green, but Japanese people say it means blue. Japanese
            books on colours tell us that there are four tertiary colours: red,
            blue, white and black, and that all others are shades of those four
            main ones. Ao, therefore, is a sort of ideal blue, halfway between
            green and blue. The sky is said to be blue, but it is a different
            shade of ao than a traffic light is. Tree leaves are said to be
            green, but green is a shade of ao, like crimson is a shade of red.To
            read an interesting debate on the nature of "blueness", visit
            http://server5.ezboard.com/fhumanjapanesejapanesegrammar.showMessage?
            topicID=20.topic. In another interesting cultural difference relating
            to colour, Japanese children always colour the sun red instead of
            yellow.

            jglick Jesse Glick added a comment -

            Correcting subcomponent.

            jglick Jesse Glick added a comment -

            I think the originally reported change could be considered fixed for those who
            want it with

            http://wiki.jenkins-ci.org/display/JENKINS/Green+Balls


              People

              • Assignee:
                Unassigned
                Reporter:
                jglick Jesse Glick
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: