Details

    • Similar Issues:

      Description

      I’m working with your plugin to launch an ALM testset and I have this issue below:
      Started by user leshalles
      [EnvInject] - Loading node environment variables.
      Building remotely on ssulnadev02 (build) in workspace /opt/jenkins_home/workspace/lesHalles-test-hp-alm
      Logged in successfully to ALM Server http://qualitycenter.sncf.fr/qcbin/ using 7907595M
      Failed to start TEST_SET ID: 2428, ALM Server URL: http://qualitycenter.sncf.fr/qcbin/ (Exception: Server returned HTTP response code: 403 for URL: http://qualitycenter.sncf.fr/qcbin/rest/domains/DSI_VOYAGEURS/projects/LES_HALLES/test-sets/2428/startruntestset)
      Failed to start TEST_SET ID:2428, run id:
      Note: You can run only functional test sets and build verification suites using this plugin. Check to make sure that the configured ID is valid (and that it is not a performance test ID).
      Empty Results
      Result Status: UNSTABLE
      Build step 'Execute HP tests using HP ALM Lab Management' changed build result to UNSTABLE
      Report not found
      Build step 'Publish HP tests result' changed build result to FAILURE
      Finished: FAILURE

      Could you help me to resolve this problem?
      Thanks in advance.

      Best regards,
      Brice

        Attachments

          Activity

          Hide
          roy_lu Roy Lu added a comment -

          The test set 2428 you configured in the plugin may not be a functional test set or build verification test. Please check it in the ALM to see what type it is. There're usually three kinds of type. Default, functional and performance.

          Show
          roy_lu Roy Lu added a comment - The test set 2428 you configured in the plugin may not be a functional test set or build verification test. Please check it in the ALM to see what type it is. There're usually three kinds of type. Default, functional and performance.
          Hide
          bviard Brice VIARD added a comment -

          I have only one test set type available in ALM and it is Default.
          Wihch one is required by your plugin? Do you have any other ALM requirements?
          thks!

          Show
          bviard Brice VIARD added a comment - I have only one test set type available in ALM and it is Default. Wihch one is required by your plugin? Do you have any other ALM requirements? thks!
          Hide
          roy_lu Roy Lu added a comment -

          Hi @Brice,
          Your are using build step 'Execute HP tests using HP ALM Lab Management' right? This build step require functional test set. But another build step doesn't have that requirement. It's 'Execute HP functional tests from HP ALM'. You can try it. Please note that the configure of test set is a little different. In this build step you need to specify the path of the test set, not the id.
          How many test set types available in you ALM depends on what edition of ALM you're using.
          Thanks.

          Show
          roy_lu Roy Lu added a comment - Hi @Brice, Your are using build step 'Execute HP tests using HP ALM Lab Management' right? This build step require functional test set. But another build step doesn't have that requirement. It's 'Execute HP functional tests from HP ALM'. You can try it. Please note that the configure of test set is a little different. In this build step you need to specify the path of the test set, not the id. How many test set types available in you ALM depends on what edition of ALM you're using. Thanks.
          Hide
          bviard Brice VIARD added a comment -

          Hi,
          I'm working with our ALM team to configure our ALM project with a lab management.
          I will test your plugin after that and I'll get back to you to close this ticket if all works fine.
          Thanks again for your support.
          Regards,
          Brice.

          Show
          bviard Brice VIARD added a comment - Hi, I'm working with our ALM team to configure our ALM project with a lab management. I will test your plugin after that and I'll get back to you to close this ticket if all works fine. Thanks again for your support. Regards, Brice.
          Hide
          bviard Brice VIARD added a comment -

          I resolved my issue, I created a lab managnement and changed the test set type from default to functional.
          Thanks again for your support on this subject.
          Best regards,
          Brice.

          Show
          bviard Brice VIARD added a comment - I resolved my issue, I created a lab managnement and changed the test set type from default to functional. Thanks again for your support on this subject. Best regards, Brice.
          Hide
          ambarishd Ambarish Dash added a comment -

          Hello,

          I am getting the same issue where my test set type is functional but getting the same error as posted above:

           
          Started by user
          cloudbees
          Building in workspace /home/cloudbees/.jenkins/workspace/RETINA_Automation_POC
          [WS-CLEANUP] Deleting project workspace...
          [WS-CLEANUP] Deferred wipeout is used...
          [WS-CLEANUP] Done
          Start login to ALM server...
          Got authenticate point:
          http://rkamv823776:80/qcbin/authentication-point/authenticate
          Logged in successfully to ALM Server
          http://rkamv823776/qcbin/
          using dasha4
          Creating session...
          Session created.
          Failed to start TEST_SET ID: 23451, ALM Server URL:
          http://rkamv823776/qcbin
          (Exception: Server returned HTTP response code: 403 for URL:
          http://rkamv823776/qcbin/rest/domains/PLAYAREA/projects/SCPDS_Performance_Test/test-sets/23451/startruntestset
          )
          Failed to start TEST_SET ID:23451, run id:
          Note: You can run only functional test sets and build verification suites using this plugin. Check to make sure that the configured ID is valid (and that it is not a performance test ID).
          Empty Results
          Result Status: UNSTABLE
          Build step 'Execute Micro Focus tests using Micro Focus ALM Lab Management' changed build result to UNSTABLE
          Recording test results
          None of the test reports contained any result
          RunResultRecorder: didn't find any test results to record
          Finished: UNSTABLE

          Show
          ambarishd Ambarish Dash added a comment - Hello, I am getting the same issue where my test set type is functional but getting the same error as posted above:   Started by user cloudbees Building in workspace /home/cloudbees/.jenkins/workspace/RETINA_Automation_POC [WS-CLEANUP] Deleting project workspace... [WS-CLEANUP] Deferred wipeout is used... [WS-CLEANUP] Done Start login to ALM server... Got authenticate point: http://rkamv823776:80/qcbin/authentication-point/authenticate Logged in successfully to ALM Server http://rkamv823776/qcbin/ using dasha4 Creating session... Session created. Failed to start TEST_SET ID: 23451, ALM Server URL: http://rkamv823776/qcbin (Exception: Server returned HTTP response code: 403 for URL: http://rkamv823776/qcbin/rest/domains/PLAYAREA/projects/SCPDS_Performance_Test/test-sets/23451/startruntestset ) Failed to start TEST_SET ID:23451, run id: Note: You can run only functional test sets and build verification suites using this plugin. Check to make sure that the configured ID is valid (and that it is not a performance test ID). Empty Results Result Status: UNSTABLE Build step 'Execute Micro Focus tests using Micro Focus ALM Lab Management' changed build result to UNSTABLE Recording test results None of the test reports contained any result RunResultRecorder: didn't find any test results to record Finished: UNSTABLE
          Hide
          ambarishd Ambarish Dash added a comment -

          Pasted error log and attached screenshot from ALM

          Show
          ambarishd Ambarish Dash added a comment - Pasted error log and attached screenshot from ALM

            People

            • Assignee:
              ofirshaked Ofir Shaked
              Reporter:
              bviard Brice VIARD
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: