Details

    • Similar Issues:
    • Epic Link:
    • Sprint:
      1.0-pre-beta-1

      Description

      According to reports by Daniel Beck, accessing the activity page in some cases (eg for blueocean job on dogfood) pints the CPU to 100% and doesn't render.

      Worth investigating.

        Attachments

          Issue Links

            Activity

            michaelneale Michael Neale created issue -
            michaelneale Michael Neale made changes -
            Field Original Value New Value
            Epic Link JENKINS-35749 [ 171790 ]
            michaelneale Michael Neale made changes -
            Issue Type Story [ 10002 ] Bug [ 1 ]
            michaelneale Michael Neale added a comment -

            Thanks Daniel - that is interesting, there may be some ineffeciency going on that tips it over the edge at that number, or something data related.

            Tom FENNELLY did you get to try this out yourself at all?

            jamesdumay James Dumay added a comment -

            Tom FENNELLY switching to a more proven table component might help this? Facebook use this one in production, it has features I want for our table component we will need soon and I'd like us to consider it. See JENKINS-37233

            jamesdumay James Dumay made changes -
            Link This issue relates to JENKINS-37233 [ JENKINS-37233 ]
            tfennelly Tom FENNELLY made changes -
            Attachment Screenshot 2016-08-08 09.28.52.png [ 33546 ]
            tfennelly Tom FENNELLY added a comment -

            Looks like the react dev tools are a big part of the problem. I think we can remove that during the build process. We should do that and see what difference it makes.

            tfennelly Tom FENNELLY added a comment -

            PR: https://github.com/jenkinsci/blueocean-plugin/pull/394

            BTW, I also notice on the console on Firefox (not on others) that there is a warning ...

            TypeError: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
            

            This is coming from babel generated code in react-redux.

            tfennelly Tom FENNELLY made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jamesdumay James Dumay made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jamesdumay James Dumay made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jbriden Jenn Briden made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Assignee:
                tfennelly Tom FENNELLY
                Reporter:
                michaelneale Michael Neale
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: