Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37229

CLI Git 1.8.3.1 (RHEL 7) reports "git fetch-pack: expected shallow list" on pipeline job shallow clone

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Won't Fix
    • Labels:
      None
    • Environment:
      Red Hat Enterprise Linux 7
      Jenkins 2.7.2
      Git plugin 2.5.3 (and 3.0.0-beta)
      Git client plugin 1.19.7 (and 2.0.0-beta)
    • Similar Issues:

      Description

      Red Hat Enterprise Linux 7 includes command line git 1.8.3.1. When the job definition defined in my jenkins-bugs commit c944ccd git repository is evaluated in a multi-branch pipeline job, it fails to clone the repository. The job definition - commit 426dce753 shows the problem when run on RHEL 7.

      The same job definition does not show the problem when run on Ubuntu 14 (git 2.9.2), Debian 8 (git 1.9), or Windows (git 2.9.2).

      Job console output looks like this:

      Fetching upstream changes from https://github.com/MarkEWaite/jenkins-bugs
       > git fetch --no-tags --progress https://github.com/MarkEWaite/jenkins-bugs +refs/heads/JENKINS-36507:refs/remotes/bugs-origin/JENKINS-36507 --prune --depth=3 # timeout=3
      ERROR: Error fetching remote repo 'bugs-origin'
      hudson.plugins.git.GitException: Failed to fetch from https://github.com/MarkEWaite/jenkins-bugs
      	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:797)
      	at hudson.plugins.git.GitSCM.retrieveChanges(GitSCM.java:1051)
      	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1082)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:109)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:83)
      	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep$StepExecutionImpl.run(SCMStep.java:73)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1$1.call(AbstractSynchronousNonBlockingStepExecution.java:52)
      	at hudson.security.ACL.impersonate(ACL.java:213)
      	at org.jenkinsci.plugins.workflow.steps.AbstractSynchronousNonBlockingStepExecution$1.run(AbstractSynchronousNonBlockingStepExecution.java:49)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: hudson.plugins.git.GitException: Command "git fetch --no-tags --progress https://github.com/MarkEWaite/jenkins-bugs +refs/heads/JENKINS-36507:refs/remotes/bugs-origin/JENKINS-36507 --prune --depth=3" returned status code 128:
      stdout: 
      stderr: fatal: git fetch-pack: expected shallow list
      fatal: The remote end hung up unexpectedly
      
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:1735)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1478)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.access$300(CliGitAPIImpl.java:64)
      	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$1.execute(CliGitAPIImpl.java:315)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:152)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:145)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      	at ......remote call to emsperformance(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      	at hudson.remoting.Channel.call(Channel.java:781)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.execute(RemoteGitImpl.java:145)
      	at sun.reflect.GeneratedMethodAccessor223.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler.invoke(RemoteGitImpl.java:131)
      	at com.sun.proxy.$Proxy71.execute(Unknown Source)
      	at hudson.plugins.git.GitSCM.fetchFrom(GitSCM.java:795)
      	... 13 more
      [Pipeline] }
      [Pipeline] // node
      [Pipeline] End of Pipeline
      ERROR: null
      Finished: FAILURE
      

        Attachments

          Issue Links

            Activity

            seanf Sean Flanigan added a comment -

            Mark Waite
            Should this be marked as a bug rather than an improvement? What would you say is the expected (or enhanced) behaviour?

            markewaite Mark Waite added a comment -

            Sean Flanigan, you're correct that it is more a bug than a feature, though it appears to be a bug in command line git 1.8.3.1. That version of command line git does not seem to have full support for shallow clone.

            markewaite Mark Waite added a comment -

            This won't be fixed, since it would either require special case handling for git 1.8.3 in the plugin (disallow shallow clone if git 1.8.3 - which I'm unwilling to do) or would require a change to command line git 1.8.3.


              People

              • Assignee:
                Unassigned
                Reporter:
                markewaite Mark Waite
              • Votes:
                2 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: