Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37272

With Jenkins 2.x Popups are empty

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: build-pipeline-plugin
    • Labels:
      None
    • Environment:
      Ubuntu, Jenkins 2.x
    • Similar Issues:

      Description

      Clicking on Start -> Javscript Console shows error:

      VM2341 build?delay=0sec:1 Refused to display 'https://jenkins.xyz.com/login?from=%2Fview%2FWeather2%2Fjob%2Fmy_fancy_job%2F%2Fbuild%3Fdelay%3D0sec' in a frame because it set 'X-Frame-Options' to 'sameorigin'.

      Popup is empty afterwards. This means you cannot start any jobs in Jenkins 2.x with this plugin directly...

        Attachments

          Activity

          jenkinsgeios Oliver HD added a comment -

          We once applied this: JENKINS-28358
          So if we stay with this old fixed version the popups work as expected - even in Jenkins 2.x...

          dalvizu Dan Alvizu added a comment -

          What version of the plugin are you running? The error ('X-Frame-Options' to 'sameorigin'.) seems to indicate jenkins is self-configured to use a different URL than the one you are accessing

          jenkinsgeios Oliver HD added a comment -

          At the time of reporting we were using the latest versions of Jenkins as well as the one of the plugin...

          dalvizu Dan Alvizu added a comment -

          Any information you can provide would be helpful, but it looks like this was a same origin issue: the console is being served from a different URL than the URL the browser first visits, and the browser rejects it. If you can't configure the URL you can change the setting, which is configurable as part of JENKINS-21881


            People

            • Assignee:
              Unassigned
              Reporter:
              jenkinsgeios Oliver HD
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: