Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3740

allow setting arbitrary system properties

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: grails-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The plugin should provide an input field for setting arbitrary additional
      system properties, just like for example the ant build does.

      Currently it is not possible to set system properties except for
      grails.work.dir, project.work.dir and server.port. There are many other
      interesting properties that users might need, including user-defined
      properties.

      Specifying -D options as target options does not work either: Using "-Dprop=foo
      war" as target (with the quotes) generates an error about missing target, and
      "war -Dprop=foo" treats the -D option as a target option and has no effect.

      With the general feature, the three properties mentioned above would no longer
      require separate input fields (which are left blank for most builds anyway).
      This is clearly a more scalable solution.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Dupe entry.

                • This issue has been marked as a duplicate of 3741 ***

              People

              • Assignee:
                jeffg2one jeffg2one
                Reporter:
                mbetter Marcus Better
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: