Details

    • Similar Issues:
    • Sprint:
      pacific, atlantic, 1.0-b05/b-06, tethys

      Description

      At this point BlueOcean doesn't have native matrix project support. till it doesn't have it, UI should redirect the user to class matrix job page when user clicks on the matrix job.

      From the pipeline object (/pipelines/:id API)

      Scipe

      • Determine if it's Matrix project type: look for hudson.matrix.MatrixProject capability
      • If it's matrix capability then use link's href to redirect the user to the received href pointing to class job. href is going to be path so it should be appended to jenkins base url before redirection
      • Open the link in a new window
      • Link should be displayed with the "exit to classic" icon

        Attachments

          Issue Links

            Activity

            vivek Vivek Pandey created issue -
            vivek Vivek Pandey made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-37018 [ JENKINS-37018 ]
            vivek Vivek Pandey made changes -
            Link This issue is related to JENKINS-37104 [ JENKINS-37104 ]
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35742 [ 171802 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-pre-beta-1 [ 86 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-beta-1 [ 96 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Assignee Ivan Meredith [ imeredith ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Assignee Ivan Meredith [ imeredith ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            michaelneale Michael Neale made changes -
            Rank Ranked lower
            michaelneale Michael Neale made changes -
            Assignee Cliff Meyers [ cliffmeyers ]
            michaelneale Michael Neale made changes -
            Assignee Cliff Meyers [ cliffmeyers ] Thorsten Scherler [ tscherler ]
            jamesdumay James Dumay made changes -
            Priority Major [ 3 ] Minor [ 4 ]
            jamesdumay James Dumay made changes -
            Assignee Thorsten Scherler [ tscherler ] Keith Zantow [ kzantow ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-beta-1 [ 96 ]
            jamesdumay James Dumay made changes -
            Sprint 1.0-beta-2 [ 111 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint 1.0-b05/b-06 [ 111 ] 26-september, 1.0-b05/b-06 [ 101, 111 ]
            jamesdumay James Dumay made changes -
            Assignee Keith Zantow [ kzantow ] Cliff Meyers [ cliffmeyers ]
            jamesdumay James Dumay made changes -
            Priority Minor [ 4 ] Trivial [ 5 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            michaelneale Michael Neale made changes -
            Sprint pacific, 1.0-b05/b-06 [ 101, 111 ] pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ] pacific, atlantic, 1.0-b05/b-06, indian [ 101, 106, 111, 126 ]
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06, indian [ 101, 106, 111, 126 ] pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ] pacific, atlantic, 1.0-b05/b-06, arctic [ 101, 106, 111, 131 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            tfennelly Tom FENNELLY made changes -
            Priority Trivial [ 5 ] Critical [ 2 ]
            tfennelly Tom FENNELLY made changes -
            Priority Critical [ 2 ] Trivial [ 5 ]
            michaelneale Michael Neale added a comment -

            note this is NOT a bug. This is to redirect matrix to classic.

            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06, arctic [ 101, 106, 111, 131 ] pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            michaelneale Michael Neale made changes -
            Link This issue relates to JENKINS-40446 [ JENKINS-40446 ]
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06 [ 101, 106, 111 ] pacific, atlantic, 1.0-b05/b-06, release candidate [ 101, 106, 111, 171 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Assignee Cliff Meyers [ cliffmeyers ] Ivan Meredith [ imeredith ]
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06, release candidate [ 101, 106, 111, 171 ] pacific, atlantic, 1.0-b05/b-06, kraken [ 101, 106, 111, 166 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06, kraken [ 101, 106, 111, 166 ] pacific, atlantic, 1.0-b05/b-06, release candidate [ 101, 106, 111, 171 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Link This issue is duplicated by JENKINS-40858 [ JENKINS-40858 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            imeredith Ivan Meredith made changes -
            Sprint pacific, atlantic, 1.0-b05/b-06, release candidate [ 101, 106, 111, 171 ] pacific, atlantic, 1.0-b05/b-06, tethys [ 101, 106, 111, 161 ]
            imeredith Ivan Meredith made changes -
            Rank Ranked lower
            imeredith Ivan Meredith made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jamesdumay James Dumay made changes -
            Link This issue is duplicated by JENKINS-40989 [ JENKINS-40989 ]
            jamesdumay James Dumay made changes -
            Description At this point BlueOcean doesn't have native matrix project support. till it doesn't have it, UI should redirect the user to class matrix job page when user clicks on the matrix job.

            From the pipeline object (/pipelines/:id API)

            - Determine if it's Matrix project type: look for hudson.matrix.MatrixProject capability
            - If it's matrix capability then use link's href to redirect the user to the received href pointing to class job. href is going to be path so it should be appended to jenkins base url before redirection
            At this point BlueOcean doesn't have native matrix project support. till it doesn't have it, UI should redirect the user to class matrix job page when user clicks on the matrix job.

            From the pipeline object (/pipelines/:id API)

            *Scipe*
            * Determine if it's Matrix project type: look for hudson.matrix.MatrixProject capability
            * If it's matrix capability then use link's href to redirect the user to the received href pointing to class job. href is going to be path so it should be appended to jenkins base url before redirection
            * Open the link in a new window
            * Link should be displayed with the "exit to classic" icon
            ** Mockup http://i.brody.com/ijRf
            ** Zeplin https://zpl.io/1kLqlz
            jamesdumay James Dumay made changes -
            Description At this point BlueOcean doesn't have native matrix project support. till it doesn't have it, UI should redirect the user to class matrix job page when user clicks on the matrix job.

            From the pipeline object (/pipelines/:id API)

            *Scipe*
            * Determine if it's Matrix project type: look for hudson.matrix.MatrixProject capability
            * If it's matrix capability then use link's href to redirect the user to the received href pointing to class job. href is going to be path so it should be appended to jenkins base url before redirection
            * Open the link in a new window
            * Link should be displayed with the "exit to classic" icon
            ** Mockup http://i.brody.com/ijRf
            ** Zeplin https://zpl.io/1kLqlz
            At this point BlueOcean doesn't have native matrix project support. till it doesn't have it, UI should redirect the user to class matrix job page when user clicks on the matrix job.

            From the pipeline object (/pipelines/:id API)

            *Scipe*
            * Determine if it's Matrix project type: look for hudson.matrix.MatrixProject capability
            * If it's matrix capability then use link's href to redirect the user to the received href pointing to class job. href is going to be path so it should be appended to jenkins base url before redirection
            * Open the link in a new window
            * Link should be displayed with the "exit to classic" icon
            ** Add "Exit to app" icon 4px to the right of the name.
            ** Mockup http://i.brody.com/ijRf
            ** Zeplin https://zpl.io/1kLqlz
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            src/main/js/page_objects/classic_jenkins/matrixCreate.js
            src/test/js/matrix.js
            http://jenkins-ci.org/commit/blueocean-acceptance-test/b92d38933b6160eaff88089f27bdebda06b7998b
            Log:
            JENKINS-37427 Check to make sure we are linking to classic Jenkins

            imeredith Ivan Meredith made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            src/main/js/page_objects/classic_jenkins/matrixCreate.js
            src/test/js/matrix.js
            http://jenkins-ci.org/commit/blueocean-acceptance-test/da4e667f405150d02f9d8883934e7e06864bc5ab
            Log:
            JENKINS-37427 Check to make sure we are linking to classic Jenkins (#99)

            imeredith Ivan Meredith made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            childnode Marcel 'childNo͡.de' Trautwein made changes -
            Link This issue relates to JENKINS-42808 [ JENKINS-42808 ]

              People

              • Assignee:
                imeredith Ivan Meredith
                Reporter:
                vivek Vivek Pandey
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: