Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37816

Binary incompatible API change in Folders 5.0 broke unique-id plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: unique-id
    • Labels:
      None
    • Similar Issues:

      Description

      SEVERE: Failed IdStoreMigratorV1ToV2.migrateIdStore
      java.lang.Error: java.lang.reflect.InvocationTargetException
      	at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)
      	at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:175)
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:998)
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:497)
      	at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:104)
      	... 8 more
      Caused by: org.jenkinsci.plugins.uniqueid.impl.IdStoreMigratorV1ToV2$IDStoreMigrationException: Failure whilst migrating com.cloudbees.hudson.plugins.folder.Folder@3489f85a[folderWithID]
      	at org.jenkinsci.plugins.uniqueid.impl.IdStoreMigratorV1ToV2.migrate(IdStoreMigratorV1ToV2.java:100)
      	at org.jenkinsci.plugins.uniqueid.impl.IdStoreMigratorV1ToV2.performMigration(IdStoreMigratorV1ToV2.java:68)
      	at org.jenkinsci.plugins.uniqueid.impl.IdStoreMigratorV1ToV2.migrateIdStore(IdStoreMigratorV1ToV2.java:59)
      	... 13 more
      Caused by: java.lang.ClassCastException: com.cloudbees.hudson.plugins.folder.properties.FolderCredentialsProvider$FolderCredentialsProperty cannot be cast to com.cloudbees.hudson.plugins.folder.FolderProperty
      	at org.jenkinsci.plugins.uniqueid.impl.FolderIdStore.remove(FolderIdStore.java:38)
      	at org.jenkinsci.plugins.uniqueid.impl.FolderIdStore.remove(FolderIdStore.java:25)
      	at org.jenkinsci.plugins.uniqueid.impl.LegacyIdStore.removeId(LegacyIdStore.java:86)
      	at org.jenkinsci.plugins.uniqueid.impl.IdStoreMigratorV1ToV2.migrate(IdStoreMigratorV1ToV2.java:90)
      	... 15 more
      

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            pom.xml
            src/main/java/org/jenkinsci/plugins/uniqueid/impl/FolderIdStore.java
            http://jenkins-ci.org/commit/unique-id-plugin/c4eda0579602bc2d8469872e3c1bcbc609df3eeb
            Log:
            JENKINS-37816 Upgrade folders plugin dependency to 5.0 and restore API compatability

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            pom.xml
            src/main/java/org/jenkinsci/plugins/uniqueid/impl/FolderIdStore.java
            http://jenkins-ci.org/commit/unique-id-plugin/d1e211fa3c479690b03597cd6e8b8bd8aec89387
            Log:
            Merge pull request #11 from jenkinsci/jenkins-37816

            JENKINS-37816 Upgrade folders plugin dependency to 5.0 and restore API compatability

            Compare: https://github.com/jenkinsci/unique-id-plugin/compare/220567d0ac74...d1e211fa3c47

            stephenconnolly Stephen Connolly added a comment -

            Version 2.1.3


              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                stephenconnolly Stephen Connolly
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: