Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38001

Cannot rename a GitHub Org Folder

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Pretty simple steps to reproduce:

      1. Create a GitHub Org Folder
      2. Go back to 'Configure'
      3. Change "Name" field to something
      4. Hit Save
      5. Confirm you want to rename
      6. Hit page with "Recomputation is currently in progress" (http://localhost:8080/job/reiseburo/rename?newName=reise&blocker=Recomputation+is+currently+in+progress)
      7. Wait forever and ever and ever

      Interestingly, this does seem to kick-off a Re-scan of the Organization, but it doesn't ever rename the folder.

        Attachments

          Issue Links

            Activity

            rtyler R. Tyler Croy created issue -
            paralin Christian Stewart added a comment -

            Any updates on this? I can reproduce. I need to rename a folder but can't.

            chancez Chance Zibolski added a comment -

            I'm hitting this myself. A huge pain because my original name had spaces in it, and it's making it a bit annoying to link to/reference in other places, but I don't really want to re-create everything just to rename it either.

            stephenconnolly Stephen Connolly made changes -
            Field Original Value New Value
            Component/s github-branch-source-plugin [ 20858 ]
            Component/s github-organization-folder-plugin [ 21427 ]
            stephenconnolly Stephen Connolly added a comment -

            Is it fixed in 2.0.0?

            portman Porter Bassett added a comment -

            I am seeing this same problem on my Multibranch Pipeline job.

            stephenconnolly Stephen Connolly made changes -
            Assignee Kohsuke Kawaguchi [ kohsuke ] CloudBees Inc. [ cloudbees ]
            stephenconnolly Stephen Connolly made changes -
            Labels scm-api-tidy-scrub
            stephenconnolly Stephen Connolly added a comment -

            Christian Stewart Chance Zibolski Porter Bassett by any chance is your master running on Windows? Is this still an issue after upgrade to CloudBees Folders 5.18 and Branch API 2.0.7?

            stephenconnolly Stephen Connolly made changes -
            Labels scm-api-tidy-scrub scm-api-tidy
            stephenconnolly Stephen Connolly added a comment -

            With the 2.0.x series of Branch API, saving the configuration only triggers a re-scan if the configuration has been changed in such a way that a re-scan is required.

            Previously, saving the configuration would always result in a re-scan and hence you could not effectively rename (unless you opened a second window and sat watching for the computation to complete)

            With the 2.0.x series you can now rename as illustrated in the attached GIF

            • The first attempt to rename fails, because the computation is in progress - this is by design
            • Then we confirm that the computation has completed and now the rename succeeds

            stephenconnolly Stephen Connolly made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Cannot Reproduce [ 5 ]
            jhill John Hill added a comment -

            Reproduced on local environment.

            jhill John Hill made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            jamesdumay James Dumay made changes -
            Labels scm-api-tidy org-folder scm-api-tidy
            stephenconnolly Stephen Connolly made changes -
            Attachment jenkins-38001.gif [ 39053 ]
            stephenconnolly Stephen Connolly added a comment -

            I claim this is fixed with the latest plugins:

            stephenconnolly Stephen Connolly made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal OSS-2050 (Web Link)" [ 18447 ]

              People

              • Assignee:
                cloudbees CloudBees Inc.
                Reporter:
                rtyler R. Tyler Croy
              • Votes:
                2 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: