Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38122

Intermittent error when using withMaven

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: pipeline-maven-plugin
    • Labels:
      None
    • Environment:
      Jenkins v2.3
      pipeline-maven-plugin v0.2
    • Similar Issues:

      Description

      My build scripts fail intermittently on the withMaven step. This configuration did work correctly when I first added it. It will still work occasionally, but usually produces the below error. I have not yet found a pattern as to when it does or doesn't work.

      The call in the Jenkinsfile:
      withMaven(maven: 'maven-3', mavenSettingsConfig: 'global-settings')

      I turned on logging for the plugin:
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Maven: maven-3
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Jdk: null
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      MavenOpts: null
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Settings Config: global-settings
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Settings FilePath: null
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Computer:
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Env:

      {GRADLE_HOME=/usr/local/gradle, HOME=, JAVA_HOME=/usr/lib/jvm/java, JAVA_OPTS=, JENKINS_HOME=/var/jenkins, M2=/usr/local/apache-maven/bin, M2_HOME=/usr/local/apache-maven, NLSPATH=/usr/dt/lib/nls/msg/%L/%N.cat, PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin, PORT=5000, SUPERVISOR_ENABLED=1, SUPERVISOR_GROUP_NAME=application, SUPERVISOR_PROCESS_NAME=application-web-1, SUPERVISOR_SERVER_URL=unix:///tmp/supervisor.sock, TERM=linux, UPSTART_INSTANCE=, UPSTART_JOB=supervisord, XFILESEARCHPATH=/usr/dt/app-defaults/%L/Dt}

      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Setting up maven
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Maven Installation parameter: maven-3
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Found maven installation on null
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Found exec for maven on: /var/jenkins/tools/hudson.tasks.Maven_MavenInstallation/maven-3/bin/mvn
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Using temp dir: /var/jenkins/workspace/Rachio/com.rachio.core/master@tmp/withMaven8a7377b3
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Created config file /var/jenkins/workspace/Rachio/com.rachio.core/master@tmp/withMaven8a7377b3/settings.xml
      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Generated wrapper: #!/bin/sh -e
      echo ----- withMaven Wrapper script -----
      /var/jenkins/tools/hudson.tasks.Maven_MavenInstallation/maven-3/bin/mvn --settings /var/jenkins/workspace/Rachio/com.rachio.core/master@tmp/withMaven8a7377b3/settings.xml --batch-mode --show-version "$@"

      Sep 12, 2016 2:53:08 AM FINE org.jenkinsci.plugins.pipeline.maven.WithMavenStepExecution
      Overrides:

      {M2_HOME=/var/jenkins/tools/hudson.tasks.Maven_MavenInstallation/maven-3, MAVEN_HOME=/var/jenkins/tools/hudson.tasks.Maven_MavenInstallation/maven-3, MAVEN_TERMINATE_CMD=on, MVN_SETTINGS=/var/jenkins/workspace/Rachio/com.rachio.core/master@tmp/withMaven8a7377b3/settings.xml, PATH+MAVEN=/var/jenkins/workspace/Rachio/com.rachio.core/master@tmp/withMaven8a7377b3}

      The relevant part of the build logs:
      [Pipeline] withMaven
      Using Maven Installation maven-3
      Using maven exec: /var/jenkins/tools/hudson.tasks.Maven_MavenInstallation/maven-3/bin/mvn
      Using settings config with name Global Settings
      Replacing all maven server entries not found in credentials list is true
      [Pipeline]

      { [Pipeline] // withMaven [Pipeline] }

      [Pipeline] // node
      [Pipeline] End of Pipeline

      GitHub has been notified of this commit?s build result

      java.lang.RuntimeException: Failed to serialize org.jenkinsci.plugins.workflow.support.storage.SimpleXStreamFlowNodeStorage$Tag#actions for class org.jenkinsci.plugins.workflow.support.storage.SimpleXStreamFlowNodeStorage$Tag
      at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:215)
      at hudson.util.RobustReflectionConverter$2.visit(RobustReflectionConverter.java:183)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:138)
      at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:168)
      at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:109)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:43)
      at com.thoughtworks.xstream.core.TreeMarshaller.start(TreeMarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.marshal(AbstractTreeMarshallingStrategy.java:37)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:1026)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:1015)
      at com.thoughtworks.xstream.XStream.toXML(XStream.java:988)
      at hudson.XmlFile.write(XmlFile.java:178)
      at org.jenkinsci.plugins.workflow.support.storage.SimpleXStreamFlowNodeStorage.saveActions(SimpleXStreamFlowNodeStorage.java:109)
      at org.jenkinsci.plugins.workflow.cps.CpsFlowExecution.saveActions(CpsFlowExecution.java:881)
      at org.jenkinsci.plugins.workflow.graph.FlowNode.save(FlowNode.java:312)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.persist(FlowNode.java:299)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.add(FlowNode.java:275)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.add(FlowNode.java:266)
      at java.util.AbstractList.add(AbstractList.java:108)
      at hudson.model.Actionable.addAction(Actionable.java:129)
      at org.jenkinsci.plugins.workflow.cps.FlowHead.markIfFail(FlowHead.java:142)
      at org.jenkinsci.plugins.workflow.cps.DSL.invokeStep(DSL.java:203)
      at org.jenkinsci.plugins.workflow.cps.DSL.invokeMethod(DSL.java:124)
      at org.jenkinsci.plugins.workflow.cps.CpsScript.invokeMethod(CpsScript.java:117)
      at groovy.lang.GroovyObject$invokeMethod.call(Unknown Source)
      at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:48)
      at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:113)
      at org.kohsuke.groovy.sandbox.impl.Checker$1.call(Checker.java:151)
      at org.kohsuke.groovy.sandbox.GroovyInterceptor.onMethodCall(GroovyInterceptor.java:21)
      at org.jenkinsci.plugins.scriptsecurity.sandbox.groovy.SandboxInterceptor.onMethodCall(SandboxInterceptor.java:115)
      at org.kohsuke.groovy.sandbox.impl.Checker$1.call(Checker.java:149)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:146)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:123)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:123)
      at com.cloudbees.groovy.cps.sandbox.SandboxInvoker.methodCall(SandboxInvoker.java:16)
      at WorkflowScript.run(WorkflowScript:23)
      at __cps.transform__(Native Method)
      at com.cloudbees.groovy.cps.impl.ContinuationGroup.methodCall(ContinuationGroup.java:48)
      at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.dispatchOrArg(FunctionCallBlock.java:109)
      at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.fixArg(FunctionCallBlock.java:82)
      at sun.reflect.GeneratedMethodAccessor231.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.dispatch(CollectionLiteralBlock.java:55)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.item(CollectionLiteralBlock.java:45)
      at sun.reflect.GeneratedMethodAccessor184.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.dispatch(CollectionLiteralBlock.java:55)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.item(CollectionLiteralBlock.java:45)
      at sun.reflect.GeneratedMethodAccessor184.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      at com.cloudbees.groovy.cps.impl.ContinuationGroup.methodCall(ContinuationGroup.java:50)
      at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.dispatchOrArg(FunctionCallBlock.java:109)
      at com.cloudbees.groovy.cps.impl.FunctionCallBlock$ContinuationImpl.fixArg(FunctionCallBlock.java:82)
      at sun.reflect.GeneratedMethodAccessor231.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.dispatch(CollectionLiteralBlock.java:55)
      at com.cloudbees.groovy.cps.impl.CollectionLiteralBlock$ContinuationImpl.item(CollectionLiteralBlock.java:45)
      at sun.reflect.GeneratedMethodAccessor184.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:497)
      at com.cloudbees.groovy.cps.impl.ContinuationPtr$ContinuationImpl.receive(ContinuationPtr.java:72)
      at com.cloudbees.groovy.cps.impl.ConstantBlock.eval(ConstantBlock.java:21)
      at com.cloudbees.groovy.cps.Next.step(Next.java:58)
      at com.cloudbees.groovy.cps.Continuable.run0(Continuable.java:154)
      at org.jenkinsci.plugins.workflow.cps.SandboxContinuable.access$001(SandboxContinuable.java:18)
      at org.jenkinsci.plugins.workflow.cps.SandboxContinuable$1.call(SandboxContinuable.java:33)
      at org.jenkinsci.plugins.workflow.cps.SandboxContinuable$1.call(SandboxContinuable.java:30)
      at org.jenkinsci.plugins.scriptsecurity.sandbox.groovy.GroovySandbox.runInSandbox(GroovySandbox.java:108)
      at org.jenkinsci.plugins.workflow.cps.SandboxContinuable.run0(SandboxContinuable.java:30)
      at org.jenkinsci.plugins.workflow.cps.CpsThread.runNextChunk(CpsThread.java:164)
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup.run(CpsThreadGroup.java:361)
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup.access$100(CpsThreadGroup.java:80)
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$2.call(CpsThreadGroup.java:236)
      at org.jenkinsci.plugins.workflow.cps.CpsThreadGroup$2.call(CpsThreadGroup.java:226)
      at org.jenkinsci.plugins.workflow.cps.CpsVmExecutorService$2.call(CpsVmExecutorService.java:47)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:112)
      at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.RuntimeException: Failed to serialize org.jenkinsci.plugins.workflow.actions.ErrorAction#error for class org.jenkinsci.plugins.workflow.actions.ErrorAction
      at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:215)
      at hudson.util.RobustReflectionConverter$2.visit(RobustReflectionConverter.java:183)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:138)
      at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:168)
      at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:109)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:43)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller$1.convertAnother(AbstractReferenceMarshaller.java:88)
      at com.thoughtworks.xstream.converters.collections.AbstractCollectionConverter.writeItem(AbstractCollectionConverter.java:64)
      at com.thoughtworks.xstream.converters.collections.ArrayConverter.marshal(ArrayConverter.java:45)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller$1.convertAnother(AbstractReferenceMarshaller.java:84)
      at hudson.util.RobustReflectionConverter.marshallField(RobustReflectionConverter.java:224)
      at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:211)
      at hudson.util.RobustReflectionConverter$2.visit(RobustReflectionConverter.java:183)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:138)
      at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:168)
      at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:109)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:43)
      at com.thoughtworks.xstream.core.TreeMarshaller.start(TreeMarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.marshal(AbstractTreeMarshallingStrategy.java:37)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:1026)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:1015)
      at com.thoughtworks.xstream.XStream.toXML(XStream.java:988)
      at hudson.XmlFile.write(XmlFile.java:178)
      at org.jenkinsci.plugins.workflow.support.storage.SimpleXStreamFlowNodeStorage.saveActions(SimpleXStreamFlowNodeStorage.java:109)
      at org.jenkinsci.plugins.workflow.cps.CpsFlowExecution.saveActions(CpsFlowExecution.java:881)
      at org.jenkinsci.plugins.workflow.graph.FlowNode.save(FlowNode.java:312)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.persist(FlowNode.java:299)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.add(FlowNode.java:275)
      at org.jenkinsci.plugins.workflow.graph.FlowNode$1.add(FlowNode.java:266)
      at java.util.AbstractList.add(AbstractList.java:108)
      at hudson.model.Actionable.addAction(Actionable.java:129)
      at org.jenkinsci.plugins.workflow.cps.FlowHead.markIfFail(FlowHead.java:142)
      at org.jenkinsci.plugins.workflow.cps.DSL.invokeStep(DSL.java:203)
      at org.jenkinsci.plugins.workflow.cps.DSL.invokeMethod(DSL.java:124)
      at org.jenkinsci.plugins.workflow.cps.CpsScript.invokeMethod(CpsScript.java:117)
      at groovy.lang.GroovyObject$invokeMethod.call(Unknown Source)
      at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:48)
      at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:113)
      at org.kohsuke.groovy.sandbox.impl.Checker$1.call(Checker.java:151)
      at org.kohsuke.groovy.sandbox.GroovyInterceptor.onMethodCall(GroovyInterceptor.java:21)
      at org.jenkinsci.plugins.scriptsecurity.sandbox.groovy.SandboxInterceptor.onMethodCall(SandboxInterceptor.java:115)
      at org.kohsuke.groovy.sandbox.impl.Checker$1.call(Checker.java:149)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:146)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:123)
      at org.kohsuke.groovy.sandbox.impl.Checker.checkedCall(Checker.java:123)
      at com.cloudbees.groovy.cps.sandbox.SandboxInvoker.methodCall(SandboxInvoker.java:16)
      ... 54 more
      Caused by: java.lang.UnsupportedOperationException: Refusing to marshal com.google.inject.ConfigurationException for security reasons
      at hudson.util.XStream2$BlacklistedTypesConverter.marshal(XStream2.java:442)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller$1.convertAnother(AbstractReferenceMarshaller.java:84)
      at hudson.util.RobustReflectionConverter.marshallField(RobustReflectionConverter.java:224)
      at hudson.util.RobustReflectionConverter$2.writeField(RobustReflectionConverter.java:211)
      ... 105 more
      Finished: FAILURE

        Attachments

          Activity

          danjasek Dan Jasek added a comment -

          My mistake. Error is in different plugin.

          dcharkes Daco Harkes added a comment -

          How did you figure out which plugin the error is in?

          I have a similar error, after a Jenkins update my builds stopped working.

          (Though my stacktrace refers to `Caused by: java.lang.UnsupportedOperationException: Refusing to marshal com.google.inject.CreationException for security reasons` rather than `ConfigurationException`.)


            People

            • Assignee:
              alobato Alvaro Lobato
              Reporter:
              danjasek Dan Jasek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: