Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3813

java.io.IOException: Unable to delete <FOLDER_NAME> - files in dir: [<WEB_REFERENCE_FILE>]

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I receive the following error when building about 90% of my builds. The other
      10% it works fine. I make no changes between the times it succeeds and the
      times it fails. I'm building in IE6 accessing the Hudson admin section. The
      delete is occurring because it is wiping out the workspace each time; but
      obviously failing.

      Started by user anonymous
      [workspace] $ e:\tfs\tf.exe workspaces -format:brief -
      server:http://<server>:8080 ********
      No workspace matching *;<USER_ID> on computer <COMPUTER_NAME> found in Team
      Foundation Server http://<server>:8080.
      FATAL: Unable to delete <FOLDER_NAME_IN_PROJECT> - files in dir:
      <WEB_REFERENCE_FILE_IN_PROJECT>
      java.io.IOException: Unable to delete <FOLDER_NAME> - files in dir:
      [<WEB_REFERENCE_FILE>]
      at hudson.Util.deleteFile(Util.java:218)
      at hudson.Util.deleteRecursive(Util.java:251)
      at hudson.Util.deleteContentsRecursive(Util.java:185)
      at hudson.Util.deleteRecursive(Util.java:250)
      at hudson.Util.deleteContentsRecursive(Util.java:185)
      at hudson.Util.deleteRecursive(Util.java:250)
      at hudson.Util.deleteContentsRecursive(Util.java:185)
      at hudson.FilePath$11.invoke(FilePath.java:719)
      at hudson.FilePath$11.invoke(FilePath.java:717)
      at hudson.FilePath.act(FilePath.java:635)
      at hudson.FilePath.deleteContents(FilePath.java:717)
      at hudson.plugins.tfs.actions.CheckoutAction.checkout
      (CheckoutAction.java:40)
      at hudson.plugins.tfs.TeamFoundationServerScm.checkout
      (TeamFoundationServerScm.java:143)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:830)
      at hudson.model.AbstractBuild$AbstractRunner.checkout
      (AbstractBuild.java:314)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:266)
      at hudson.model.Run.run(Run.java:927)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)

        Attachments

          Issue Links

            Activity

            redsolo redsolo added a comment -

            i cant see that this is related to the TFS plugin, as you re-opened it referenced the job-history plugin. This issue is marked as belonging to the tfs plugin, and not the job-history plugin. Im just doing some cleaning for a upcoming tfs release.

            mfriedenhagen Mirko Friedenhagen added a comment - - edited

            Please submit a new bug for the jobConfigHistory-Plugin then instead of discussing this in this unrelated bug. As I wrote above I am somewhat at loss regarding this issue, we do not run hudson on a Windows-Server and on my workstation I can not reproduce this problem.

            cforce cforce added a comment -

            Hello,

            i also reproduced problem with file access through job histoty plugin (s.a.). After i deactivted the plugin the problem immediately disappeared. I am sure that it has something todo with the job history plugin, why else this effect?
            Maybe it has something todo with "hudson on windows server" installations plus the job histoty plugin because of file access rights managment, but i gave all rights for the service acccount of tomcat/hudson was running on and the problem stayed.

            redsolo redsolo added a comment -

            Ok, can not reproduce the TFS problem. Please open up a new issue for jobconfig (or misc).

            mfriedenhagen Mirko Friedenhagen added a comment -

            Putting it to back to TFS, though I would suggest closing this bug as "Can not reproduce", there are lots of stacktraces in this issue which IMHO only have Windows-OSes in common, but are otherwise unrelated .


              People

              • Assignee:
                redsolo redsolo
                Reporter:
                dougbrinkmeier dougbrinkmeier
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: