Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3829

"ERROR: Failed to parse POMs" using slave executor

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: remoting
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am using Hudson 1.306 with Maven 2.0.9 as Master (OpenSuse) and creating a
      Hudson slave on Windows2003 VMware. This all works fine. The connection to the
      slave is up and running.
      When I now start building a Maven project in the slave executor the following
      error appears:
      ERROR: Failed to parse POMs

      org.apache.maven.embedder.MavenEmbedderException: Cannot lookup required component.

      at hudson.maven.MavenEmbedder.start(MavenEmbedder.java:722)

      at hudson.maven.MavenUtil.createEmbedder(MavenUtil.java:116)

      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:728)

      at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:676)

      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1638)

      at hudson.remoting.UserRequest.perform(UserRequest.java:103)

      at hudson.remoting.UserRequest.perform(UserRequest.java:47)

      at hudson.remoting.Request$2.run(Request.java:236)

      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

      at java.util.concurrent.FutureTask.run(Unknown Source)

      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

      at hudson.remoting.Engine$1$1.run(Engine.java:54)

      at java.lang.Thread.run(Unknown Source)

      Caused by:
      org.codehaus.plexus.component.repository.exception.ComponentLookupException:
      Unable to lookup component 'org.apache.maven.lifecycle.LifecycleExecutor', it
      could not be started

      at
      org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:339)

      at org.codehaus.plexus.embed.Embedder.lookup(Embedder.java:78)

      at hudson.maven.MavenEmbedder.start(MavenEmbedder.java:700)

      ... 14 more

      Caused by:
      org.codehaus.plexus.component.repository.exception.ComponentLifecycleException:
      Error starting component

      at
      org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:109)

      at
      org.codehaus.plexus.component.manager.AbstractComponentManager.createComponentInstance(AbstractComponentManager.java:95)

      at
      org.codehaus.plexus.component.manager.ClassicSingletonComponentManager.getComponent(ClassicSingletonComponentManager.java:92)

      at
      org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:331)

      ... 16 more

      Caused by:
      org.codehaus.plexus.personality.plexus.lifecycle.phase.PhaseExecutionException:
      Error composing component

      at
      org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:33)

      at
      org.codehaus.plexus.lifecycle.AbstractLifecycleHandler.start(AbstractLifecycleHandler.java:101)

      at
      org.codehaus.plexus.component.manager.AbstractComponentManager.startComponentLifecycle(AbstractComponentManager.java:105)

      ... 19 more

      Caused by: org.codehaus.plexus.component.composition.CompositionException:
      Component composition failed. No field of type: 'interface
      org.apache.maven.project.MavenProjectBuilder' exists in class
      'org.apache.maven.lifecycle.LifecycleExecutorInterceptor'. Component: role:
      'org.apache.maven.lifecycle.LifecycleExecutor', implementation:
      'org.apache.maven.lifecycle.LifecycleExecutorInterceptor'

      at
      org.codehaus.plexus.component.composition.FieldComponentComposer.getFieldByType(FieldComponentComposer.java:305)

      at
      org.codehaus.plexus.component.composition.FieldComponentComposer.findMatchingField(FieldComponentComposer.java:204)

      at
      org.codehaus.plexus.component.composition.FieldComponentComposer.assembleComponent(FieldComponentComposer.java:62)

      at
      org.codehaus.plexus.component.composition.DefaultComponentComposerManager.assembleComponent(DefaultComponentComposerManager.java:68)

      at
      org.codehaus.plexus.DefaultPlexusContainer.composeComponent(DefaultPlexusContainer.java:1486)

      at
      org.codehaus.plexus.personality.plexus.lifecycle.phase.CompositionPhase.execute(CompositionPhase.java:29)

      ... 21 more

      Finished: FAILURE

        Attachments

          Activity

          tpijl tpijl created issue -
          evernat evernat added a comment -

          Duplicate of JENKINS-3706

          evernat evernat made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 133902 ] JNJira + In-Review [ 186707 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              tpijl tpijl
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: