Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38572

Support Core Plugin gets java.lang.NoClassDefFoundError: jenkins/plugins/asynchttpclient/AHCUtils at startup

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: support-core-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.23
      Support Core Plugin 2.33
    • Similar Issues:

      Description

      When Jenkins is started, I see the following stack trace in the log:

      Could not attach 'update-center.md' to support bundle
      java.lang.NoClassDefFoundError: jenkins/plugins/asynchttpclient/AHCUtils
      	at com.cloudbees.jenkins.support.impl.UpdateCenter$1.writeTo(UpdateCenter.java:70)
      	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:358)
      	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:274)
      	at com.cloudbees.jenkins.support.SupportPlugin$PeriodicWorkImpl$1.run(SupportPlugin.java:724)
      	at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.ClassNotFoundException: jenkins.plugins.asynchttpclient.AHCUtils
      	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1373)
      	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1326)
      	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1079)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
      	... 5 more
      

      I first noticed this fairly recently, so I suspect that it was introduced with Support Core Plugin 2.33. I have only seen the message during initial startup.

        Attachments

          Issue Links

            Activity

            davida2009 David Aldrich added a comment -

            I see this exception hourly.

            mwebber Matthew Webber added a comment -

            I originally said "I have only seen the message during initial startup", but I just looked now, and see another occurrence in the log. That is consistent with the davida2009's comment.

            schristou Steven Christou added a comment -

            Ops, I'm sorry. I'll fix this ASAP.

            davida2009 David Aldrich added a comment -

            Please can the fix be released?

            pimyjenkins Rob Pimentel added a comment -

            I am seeing this hourly as well.

            mwebber Matthew Webber added a comment -

            I'm still seeing this also - on Jenkins 2.31. Waiting on someone to merge the pull request.

            duemir Denys Digtiar added a comment -

            Should be fixed since support-core-2.34.
            Matthew Webber Please re-open if it is not actually the case.


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                mwebber Matthew Webber
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: