Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38579

"All" view hyperlinks get localized, conflict with BlueOcean

    Details

    • Similar Issues:
    • Epic Link:

      Description

      I have started a new Jenkins instance when my browser had a Russian locale enabled by default. In such case AllView has a name "Все" instead of "All". It impacts hyperlinks within the entire UI (e.g. "http://localhost:8080/jenkins/view/Все/newJob").

      After the installation f my instance I installed Locale plugin and configured it to use the en-US locale. When I try to create a new job in BlueOcean, it redirects me to http://localhost:8080/jenkins/view/All/newJob. For this link I get a 404 error.

      See the attached screenshots.

        Attachments

        1. AllView.png
          AllView.png
          189 kB
        2. Error.png
          Error.png
          31 kB
        3. Locale plugin.png
          Locale plugin.png
          33 kB

          Issue Links

            Activity

            ks_nenasheva Kseniia Nenasheva created issue -
            ks_nenasheva Kseniia Nenasheva made changes -
            Field Original Value New Value
            Attachment AllView.png [ 34123 ]
            Attachment Error.png [ 34124 ]
            Attachment Locale plugin.png [ 34125 ]
            danielbeck Daniel Beck made changes -
            Component/s core [ 15593 ]
            danielbeck Daniel Beck added a comment -

            Not a core issue. If the 'All' name is hardcoded, that's just plain wrong as users can change the default view, and even remove the 'All; view.

            https://wiki.jenkins-ci.org/display/JENKINS/Editing+or+Replacing+the+All+View

            ks_nenasheva Kseniia Nenasheva added a comment -

            Jenkins has created the AllView with a name in Russian on the first startup. I have not changed anything on my own. I think Jenkins core somehow takes Display name instead of the name.

            ks_nenasheva Kseniia Nenasheva made changes -
            Component/s core [ 15593 ]
            danielbeck Daniel Beck made changes -
            Component/s core [ 15593 ]
            danielbeck Daniel Beck added a comment -

            As I wrote above, users can change which view is the default, and even delete the 'All' (or Bce) view, so even if we moved to localizing separate display names, it would still be a bug in Blue Ocean and have the same fix – Jenkins.getInstance().getPrimaryView().getName()

            ks_nenasheva Kseniia Nenasheva added a comment -

            Yes, I agree that this is a bug in Blue Ocean.
            But, IMHO, the core should not create a view using the locale. Can I create new ticket for only core (without Blue Ocean) ?

            danielbeck Daniel Beck added a comment -

            Sure, file away.

            ks_nenasheva Kseniia Nenasheva added a comment -

            Daniel Beck, thanks!
            Done. Ticket JENKINS-38606

            michaelneale Michael Neale made changes -
            Link This issue duplicates JENKINS-36610 [ JENKINS-36610 ]
            michaelneale Michael Neale made changes -
            Epic Link JENKINS-35749 [ 171790 ]
            michaelneale Michael Neale added a comment -

            Thanks Kseniia Nenasheva - I have linked this as a dupe of another ticket.
            This link should not be hard coded in blue ocean (there is some work under way for i18n) but also, this link shouldn't need to exist in the header once the create-pipeline features are there.

            so if it is ok, I will close this (and just link to it for the details).

            michaelneale Michael Neale made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Duplicate [ 3 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                ks_nenasheva Kseniia Nenasheva
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: