Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38668

${CHANGES_SINCE_LAST_SUCCESS} no longer displays "No changes" when there are no new SCM changes

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: token-macro-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.23
      Email Extension Plugin 2.51
      Token Macro Plugin 2.0
      Git plugin 3.0.0
    • Similar Issues:

      Description

      I recently updated my plugins and I think one of them caused the emails to no longer display "No changes" then there are no new SCM changes in the build.

      In my case I am using Git.

      Here is our usual output config:
      ${CHANGES_SINCE_LAST_BUILD, showDependencies=true, format="\n[%r]\n\t%m\t\t%a - %d\n%p"}

      I tired using no attributes and it still did the same thing.

      I also tried using/changing the default attribute and it still did not show anything.

      It still properly displays the SCM changes when there are some to show.

        Attachments

        1. build.log
          18 kB
        2. build.log
          2 kB
        3. token-macro.hpi
          436 kB

          Activity

            People

            • Assignee:
              slide_o_mix Alex Earl
              Reporter:
              tspencer3 Thomas Spencer
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: