Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38686

Schedule plugin doesnt work with https

    Details

    • Similar Issues:

      Description

      After selecting start time "schedule plugin" redirect page to url starting with HTTP. If only https is allowed for Jenkins, then we got an error.

        Attachments

          Activity

          Hide
          aesirot Anton Sirotinkin added a comment -

          Error exists in 3.3 and 3.4 plugin version

          Show
          aesirot Anton Sirotinkin added a comment - Error exists in 3.3 and 3.4 plugin version
          Hide
          pingunaut Martin Spielmann added a comment - - edited

          Anton Sirotinkin this issue is fixed with version 0.4.0-alpha2. Do you have the chance to test this alpha version from the experimental update center?

          Show
          pingunaut Martin Spielmann added a comment - - edited Anton Sirotinkin this issue is fixed with version 0.4.0-alpha2. Do you have the chance to test this alpha version from the experimental update center ?
          Hide
          pingunaut Martin Spielmann added a comment -

          fixed with 0.4.0

          Show
          pingunaut Martin Spielmann added a comment - fixed with 0.4.0
          Hide
          mipasco Mike Scott added a comment -

          Hello Martin,

          I am still seeing this issue on a fresh install of the plugin (0.4.0).  Same behavior.  here's a snippet of the source to show at some point in the call it switches to http:, which fails to create the scheduled run.  We are running our jenkins on https: via AWS ECS. 

           

          Submitting your changes to the server...
          </p><script src="/plugin/schedule-build/scheduleRequest.js"></script><script>sumbitScheduleRequest("http://<website>/job/test-job/", 15240, false);</script></div></div><footer><div class="container-fluid"><div class="row"><div class="col-md-6" id="footer"></div><div class="col-md-18"><span class="page_generated">Page generated: Sep 15, 2017 5:48:53 PM UTC</span><span class="jenkins_ver"><a href="https://jenkins.io/">Jenkins ver. 2.60.3</a></span><div id="l10n-dialog" class="dialog"></div><div id="l10n-footer" style="display:none; float:left"><a href="#" onclick="return showTranslationDialog();"><img src="/static/07947b1a/plugin/translation/flags.png" />
          Help us localize this page

          Show
          mipasco Mike Scott added a comment - Hello Martin, I am still seeing this issue on a fresh install of the plugin (0.4.0).  Same behavior.  here's a snippet of the source to show at some point in the call it switches to http:, which fails to create the scheduled run.  We are running our jenkins on https: via AWS ECS.    Submitting your changes to the server... </p><script src="/plugin/schedule-build/scheduleRequest.js"></script><script>sumbitScheduleRequest(" http ://<website>/job/test-job/", 15240, false);</script></div></div><footer><div class="container-fluid"><div class="row"><div class="col-md-6" id="footer"></div><div class="col-md-18"><span class="page_generated">Page generated: Sep 15, 2017 5:48:53 PM UTC</span><span class="jenkins_ver"><a href="https://jenkins.io/">Jenkins ver. 2.60.3</a></span><div id="l10n-dialog" class="dialog"></div><div id="l10n-footer" style="display:none; float:left"><a href="#" onclick="return showTranslationDialog();"><img src="/static/07947b1a/plugin/translation/flags.png" /> Help us localize this page
          Hide
          pingunaut Martin Spielmann added a comment -

          Thanks a Lot for your detailed feedback. I'll try to reproduce anderen fix this asap. Unfortunately I won't bei able to have a look before nextcloud week

          Show
          pingunaut Martin Spielmann added a comment - Thanks a Lot for your detailed feedback. I'll try to reproduce anderen fix this asap. Unfortunately I won't bei able to have a look before nextcloud week
          Hide
          mipasco Mike Scott added a comment -

          Hello Martin,

          our jenkins instance was not configured correctly. Specifically we had our jenkins location URL with an HTTP address.  After modifying this to HTTPS, the redirect worked correctly.. I should have been more careful. apologies. What threw me is there were other calls on the page that used https://...., but the one I posted was http://... that is what led me away from jenkins config.  Again, apologies and thank you for this wonderful  plugin.  Testing it out today...ahead of deployment

          Show
          mipasco Mike Scott added a comment - Hello Martin, our jenkins instance was not configured correctly. Specifically we had our jenkins location URL with an HTTP address.  After modifying this to HTTPS, the redirect worked correctly.. I should have been more careful. apologies. What threw me is there were other calls on the page that used https://....,  but the one I posted was http://...  that is what led me away from jenkins config.  Again, apologies and thank you for this wonderful  plugin.  Testing it out today...ahead of deployment
          Hide
          pingunaut Martin Spielmann added a comment -

          Hello Mike,

          thanks for your feedback. I'm glad that everything is working for you now

          I think I'll add a small trouble shooting Section to the wiki page and add your experience there.

          Best regards,

          Martin

          Show
          pingunaut Martin Spielmann added a comment - Hello Mike, thanks for your feedback. I'm glad that everything is working for you now I think I'll add a small trouble shooting Section to the wiki page and add your experience there. Best regards, Martin

            People

            • Assignee:
              pingunaut Martin Spielmann
              Reporter:
              aesirot Anton Sirotinkin
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: