Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38719

ConsoleAnnotatorFactory serves stale JavaScript and CSS when a plugin is upgraded/downgraded

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Latest Jenkins as of 2016-08-05
    • Similar Issues:
    • Released As:
      toward 2.152

      Description

      When a plugin extends ConsoleAnnotatorFactory, it can serve a JavaScript file and a CSS file. These resources expire after a day, which means that after upgrading or downgrading the plugin, they remain out of date for a while. This is most likely the cause of JENKINS-31213.

      It is possible to work around this within the plugins by renaming the ConsoleAnnotatorFactory subclass every time the JavaScript or CSS files are changed. I wasn't able to find a better workaround - see this comment.

      This could be fixed within Jenkins by including the plugin version or the SESSION_HASH in the URL. The plugin version would allow the resources to be cached for longer, but the SESSION_HASH is probably easier to implement.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Another fix at PR 3757 (sorry Daniel Beck I had no idea this was even a filed issue).


              People

              • Assignee:
                jglick Jesse Glick
                Reporter:
                stevengbrown Steven G Brown
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: