Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      FindBugs.4.65
      Jenkins 2.7.4
      maven-findbugs-plugin 2.5.5
      Java 1.7
      maven 3.0.3
    • Similar Issues:

      Description

      For Maven Project FindBugs fails to load SaxParser and breaks future parser uses.

      Maven goals:

      clean site install -Dmaven.javadoc.skip=true -Dsoe.env.Unit-Test-Environment=CI --fail-never
      
      [INFO] 
      [INFO] --- maven-checkstyle-plugin:2.15:check (default) @ XxxxImpl ---
      [INFO] Starting audit...
      Audit done.
      [CHECKSTYLE] Parsing file /root/.jenkins/workspace/A_CI_Individual_1/XxxxImpl/target/checkstyle-result.xml
      [CHECKSTYLE] Successfully parsed file /root/.jenkins/workspace/A_CI_Individual_1/XxxxImpl/target/checkstyle-result.xml of module XxxxImpl with 0 unique warnings and 0 duplicates.
      [CHECKSTYLE] Computing warning deltas based on reference build #768
      [PMD] No report found for mojo check
      [INFO] 
      [INFO] --- findbugs-maven-plugin:2.5.5:findbugs (findbugs) @ XxxxImpl ---
      [INFO] Fork Value is true
      [INFO] Done FindBugs Analysis....
      Warning: Caught exception attempting to use SAX to load a SAX XMLReader 
      Warning: Exception was: org.xml.sax.SAXException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      java.lang.ClassNotFoundException: Classloading from system classloader disabled
      Warning: I will print the stack trace then carry on using the default SAX parser
      org.xml.sax.SAXException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:229)
      	at org.xml.sax.helpers.XMLReaderFactory.createXMLReader(XMLReaderFactory.java:190)
      	at org.dom4j.io.SAXHelper.createXMLReader(SAXHelper.java:83)
      	at org.dom4j.io.SAXReader.createXMLReader(SAXReader.java:894)
      	at org.dom4j.io.SAXReader.getXMLReader(SAXReader.java:715)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:435)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:365)
      	at edu.umd.cs.findbugs.PluginLoader.getPluginDescriptor(PluginLoader.java:1145)
      	at edu.umd.cs.findbugs.PluginLoader.init(PluginLoader.java:636)
      	at edu.umd.cs.findbugs.PluginLoader.<init>(PluginLoader.java:397)
      	at edu.umd.cs.findbugs.PluginLoader.loadCorePlugin(PluginLoader.java:1433)
      	at edu.umd.cs.findbugs.PluginLoader.loadInitialPlugins(PluginLoader.java:1387)
      	at edu.umd.cs.findbugs.PluginLoader.<clinit>(PluginLoader.java:154)
      	at edu.umd.cs.findbugs.DetectorFactoryCollection.getCoreResource(DetectorFactoryCollection.java:360)
      	at edu.umd.cs.findbugs.SystemProperties.loadPropertiesFromConfigFile(SystemProperties.java:77)
      	at edu.umd.cs.findbugs.SystemProperties.<clinit>(SystemProperties.java:60)
      	at edu.umd.cs.findbugs.SortedBugCollection.<clinit>(SortedBugCollection.java:96)
      	at hudson.plugins.findbugs.parser.FindBugsParser.readXml(FindBugsParser.java:368)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:266)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:204)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:182)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:150)
      	at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:325)
      	at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:283)
      	at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:234)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:203)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      	at hudson.FilePath.act(FilePath.java:1018)
      	at hudson.FilePath.act(FilePath.java:996)
      	at hudson.plugins.findbugs.FindBugsReporter.perform(FindBugsReporter.java:211)
      	at hudson.plugins.analysis.core.HealthAwareReporter.postExecute(HealthAwareReporter.java:340)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.recordMojoEnded(Maven3Builder.java:634)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.mojoSucceeded(Maven3Builder.java:615)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:87)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:228)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:365)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:117)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:181)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:136)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch4(RemoteClassLoader.java:770)
      	at hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch3(RemoteClassLoader.java:803)
      	at sun.reflect.GeneratedMethodAccessor73.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
      	at java.lang.reflect.Method.invoke(Method.java:620)
      	at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at org.jenkinsci.remoting.CallableDecorator.call(CallableDecorator.java:18)
      	at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
      	at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:274)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1157)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:627)
      	at java.lang.Thread.run(Thread.java:809)
      	at ......remote call to channel(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      	at hudson.remoting.Request.call(Request.java:172)
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:252)
      	at com.sun.proxy.$Proxy2.fetch3(Unknown Source)
      	at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:171)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      	at org.xml.sax.helpers.NewInstance.newInstance(NewInstance.java:73)
      	at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:227)
      	... 70 more
      java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:181)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:136)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.ExceptionInInitializerError
      	at edu.umd.cs.findbugs.DetectorFactoryCollection.getCoreResource(DetectorFactoryCollection.java:360)
      	at edu.umd.cs.findbugs.SystemProperties.loadPropertiesFromConfigFile(SystemProperties.java:77)
      	at edu.umd.cs.findbugs.SystemProperties.<clinit>(SystemProperties.java:60)
      	at edu.umd.cs.findbugs.SortedBugCollection.<clinit>(SortedBugCollection.java:96)
      	at hudson.plugins.findbugs.parser.FindBugsParser.readXml(FindBugsParser.java:368)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:266)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:204)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:182)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:150)
      	at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:325)
      	at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:283)
      	at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:234)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:203)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      	at hudson.FilePath.act(FilePath.java:1018)
      	at hudson.FilePath.act(FilePath.java:996)
      	at hudson.plugins.findbugs.FindBugsReporter.perform(FindBugsReporter.java:211)
      	at hudson.plugins.analysis.core.HealthAwareReporter.postExecute(HealthAwareReporter.java:340)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.recordMojoEnded(Maven3Builder.java:634)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.mojoSucceeded(Maven3Builder.java:615)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:87)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:228)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:365)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:117)
      	... 22 more
      Caused by: java.lang.IllegalStateException: Unable to load core plugin
      	at edu.umd.cs.findbugs.PluginLoader.loadCorePlugin(PluginLoader.java:1437)
      	at edu.umd.cs.findbugs.PluginLoader.loadInitialPlugins(PluginLoader.java:1387)
      	at edu.umd.cs.findbugs.PluginLoader.<clinit>(PluginLoader.java:154)
      	... 58 more
      Caused by: edu.umd.cs.findbugs.PluginException: Couldn't parse "jar:file:/root/.jenkins/cache/jars/B5/B3E591A60CC7700086E0AB02FF39C7.jar!/findbugs.xml" using org.dom4j.io.SAXReader
      	at edu.umd.cs.findbugs.PluginLoader.getPluginDescriptor(PluginLoader.java:1147)
      	at edu.umd.cs.findbugs.PluginLoader.init(PluginLoader.java:636)
      	at edu.umd.cs.findbugs.PluginLoader.<init>(PluginLoader.java:397)
      	at edu.umd.cs.findbugs.PluginLoader.loadCorePlugin(PluginLoader.java:1433)
      	... 60 more
      Caused by: org.dom4j.DocumentException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found Nested exception: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      	at org.dom4j.io.SAXReader.read(SAXReader.java:484)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:365)
      	at edu.umd.cs.findbugs.PluginLoader.getPluginDescriptor(PluginLoader.java:1145)
      	... 63 more
      Caused by: org.xml.sax.SAXException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      org.xml.sax.SAXException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at org.dom4j.io.SAXHelper.createXMLReader(SAXHelper.java:98)
      	at org.dom4j.io.SAXReader.createXMLReader(SAXReader.java:894)
      	at org.dom4j.io.SAXReader.getXMLReader(SAXReader.java:715)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:435)
      	... 65 more
      Caused by: org.xml.sax.SAXException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:229)
      	at org.xml.sax.helpers.XMLReaderFactory.createXMLReader(XMLReaderFactory.java:190)
      	at org.dom4j.io.SAXHelper.createXMLReader(SAXHelper.java:83)
      	... 68 more
      Caused by: java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch4(RemoteClassLoader.java:770)
      	at hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch3(RemoteClassLoader.java:803)
      	at sun.reflect.GeneratedMethodAccessor73.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
      	at java.lang.reflect.Method.invoke(Method.java:620)
      	at hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:884)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at org.jenkinsci.remoting.CallableDecorator.call(CallableDecorator.java:18)
      	at hudson.remoting.CallableDecoratorList$1.call(CallableDecoratorList.java:21)
      	at jenkins.util.ContextResettingExecutorService$2.call(ContextResettingExecutorService.java:46)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:274)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1157)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:627)
      	at java.lang.Thread.run(Thread.java:809)
      	at ......remote call to channel(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      	at hudson.remoting.Request.call(Request.java:172)
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:252)
      	at com.sun.proxy.$Proxy2.fetch3(Unknown Source)
      	at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:171)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      	at org.xml.sax.helpers.NewInstance.newInstance(NewInstance.java:73)
      	at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:227)
      	... 70 more
      channel stopped
      
      ERROR: Failed to parse POMs
      hudson.util.IOException2: java.lang.reflect.InvocationTargetException
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:180)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:722)
      	at ......remote call to Channel to Maven [/usr/jdk1.7.0_17/bin/java, -XX:MaxPermSize=720M, -Xmx1024M, -cp, /root/.jenkins/plugins/maven-plugin/WEB-INF/lib/maven3-agent-1.7.jar:/usr/apache-maven-3.0.5/boot/plexus-classworlds-2.4.jar, org.jvnet.hudson.maven3.agent.Maven3Main, /usr/apache-maven-3.0.5, /usr/apache-tomcat-7.0.39/webapps/jenkins/WEB-INF/lib/remoting-2.60.jar, /root/.jenkins/plugins/maven-plugin/WEB-INF/lib/maven3-interceptor-1.7.jar, /root/.jenkins/plugins/maven-plugin/WEB-INF/lib/maven3-interceptor-commons-1.7.jar, 44598](Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
      	at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      	at hudson.remoting.Channel.call(Channel.java:781)
      	at hudson.maven.ProcessCache$MavenProcess.call(ProcessCache.java:161)
      	at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:853)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
      	at hudson.model.Run.execute(Run.java:1741)
      	at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:410)
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:136)
      	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      	at hudson.remoting.Request$2.run(Request.java:332)
      	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      	at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.Exception: java.lang.reflect.InvocationTargetException
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:184)
      	... 15 more
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:601)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
      	at org.jvnet.hudson.maven3.agent.Maven3Main.launch(Maven3Main.java:181)
      	... 15 more
      Caused by: java.lang.ExceptionInInitializerError
      	at edu.umd.cs.findbugs.DetectorFactoryCollection.getCoreResource(DetectorFactoryCollection.java:360)
      	at edu.umd.cs.findbugs.SystemProperties.loadPropertiesFromConfigFile(SystemProperties.java:77)
      	at edu.umd.cs.findbugs.SystemProperties.<clinit>(SystemProperties.java:60)
      	at edu.umd.cs.findbugs.SortedBugCollection.<clinit>(SortedBugCollection.java:96)
      	at hudson.plugins.findbugs.parser.FindBugsParser.readXml(FindBugsParser.java:368)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:266)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:204)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:182)
      	at hudson.plugins.findbugs.parser.FindBugsParser.parse(FindBugsParser.java:150)
      	at hudson.plugins.analysis.core.FilesParser.parseFile(FilesParser.java:325)
      	at hudson.plugins.analysis.core.FilesParser.parseFiles(FilesParser.java:283)
      	at hudson.plugins.analysis.core.FilesParser.parserCollectionOfFiles(FilesParser.java:234)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:203)
      	at hudson.plugins.analysis.core.FilesParser.invoke(FilesParser.java:31)
      	at hudson.FilePath.act(FilePath.java:1018)
      	at hudson.FilePath.act(FilePath.java:996)
      	at hudson.plugins.findbugs.FindBugsReporter.perform(FindBugsReporter.java:211)
      	at hudson.plugins.analysis.core.HealthAwareReporter.postExecute(HealthAwareReporter.java:340)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.recordMojoEnded(Maven3Builder.java:634)
      	at hudson.maven.Maven3Builder$MavenExecutionListener.mojoSucceeded(Maven3Builder.java:615)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:87)
      	at org.apache.maven.lifecycle.internal.DefaultExecutionEventCatapult.fire(DefaultExecutionEventCatapult.java:42)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:228)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:365)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:199)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.jvnet.hudson.maven3.launcher.Maven3Launcher.main(Maven3Launcher.java:117)
      	... 22 more
      Caused by: java.lang.IllegalStateException: Unable to load core plugin
      	at edu.umd.cs.findbugs.PluginLoader.loadCorePlugin(PluginLoader.java:1437)
      	at edu.umd.cs.findbugs.PluginLoader.loadInitialPlugins(PluginLoader.java:1387)
      	at edu.umd.cs.findbugs.PluginLoader.<clinit>(PluginLoader.java:154)
      	... 58 more
      Caused by: edu.umd.cs.findbugs.PluginException: Couldn't parse "jar:file:/root/.jenkins/cache/jars/B5/B3E591A60CC7700086E0AB02FF39C7.jar!/findbugs.xml" using org.dom4j.io.SAXReader
      	at edu.umd.cs.findbugs.PluginLoader.getPluginDescriptor(PluginLoader.java:1147)
      	at edu.umd.cs.findbugs.PluginLoader.init(PluginLoader.java:636)
      	at edu.umd.cs.findbugs.PluginLoader.<init>(PluginLoader.java:397)
      	at edu.umd.cs.findbugs.PluginLoader.loadCorePlugin(PluginLoader.java:1433)
      	... 60 more
      Caused by: org.dom4j.DocumentException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found Nested exception: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
      	at org.dom4j.io.SAXReader.read(SAXReader.java:484)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:365)
      	at edu.umd.cs.findbugs.PluginLoader.getPluginDescriptor(PluginLoader.java:1145)
      	... 63 more
      Caused by: java.lang.ClassNotFoundException: Classloading from system classloader disabled
      	at org.dom4j.io.SAXHelper.createXMLReader(SAXHelper.java:98)
      	at org.dom4j.io.SAXReader.createXMLReader(SAXReader.java:894)
      	at org.dom4j.io.SAXReader.getXMLReader(SAXReader.java:715)
      	at org.dom4j.io.SAXReader.read(SAXReader.java:435)
      	... 65 more

      Looks like some old issues got back.

      As workaround works: altering Parser in mvn call:

       -Dorg.xml.sax.driver=com.sun.org.apache.xerces.internal.parsers.SAXParser

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Is Jenkins running in a container? Did you change some xerces libraries in the bootstrap folders of your installation?

            toudick Waldemar Prabucki added a comment -

            Jenkins is runing inside of apache-tomcat-7.0.39. No libraries hvae been adopted. Just thrwon in a jenkins.war. As long as I know apache is also standard installation.

            drulli Ulli Hafner added a comment -

            Ok, I see. Seems that the findbugs library (that I'm using to read the files) does some weird things that it should never do

            drulli Ulli Hafner added a comment -

            I finally removed the Xerces dependency from the findbugs parser. It is released in the beta of the new warnings plugin. Can you please check if this is working using the new plugin?

            toudick Waldemar Prabucki added a comment -

            I'm not able to verify it now as we switched to sonar in the meantime.


              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                toudick Waldemar Prabucki
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: