Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38819

Build history not visible for user who copied jobs

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Minor
    • Resolution: Not A Defect
    • Component/s: core
    • Environment:
      Jenkins 2.2
      Accessing on a Mac computer OSX 10.10.5
      Browsers: latest Chrome, Firefox 47
    • Similar Issues:

      Description

      Sorry I can't give full details of my Jenkins installation, I am an individual user in a large organisation. We are using Jenkins 2.2

      The problem I am facing is that I cannot see any build history in the left of any job I view. Screenshot attached. The builds are there, I can reach details of them through other means.

      Colleagues can all see the recent builds and link through to them, when they hit "build" they see the new build appear and the status updates. Until a couple of days ago, so could I. Now, when I hit build I get no feedback. The history/current build section of my views is now missing. If I hit build then I can refresh the page and see the latest one in the main section but not the left nav. The builds are not disappearing, but this section of the page is not available to me. I have tried rebooting my machine, switching browser and using an ingcognito window, but my user never shows this part of the job view any more.

      A colleague had a job set up which matched what I wanted to do, so rather than start from scratch I copied that job and tweaked it. I believe, due to finding JENKINS-16735 that this may have caused my issue as it seemed to happen at around the same time.

      I don't have access to logs or command line access on our Jenkins installation, but may be able to get assistance get that if it will help fix the issue.

        Attachments

          Activity

          Hide
          imdobr Ilya Dobrovolsky added a comment - - edited

          Hello all.

          I had the same issue. I was quite confused, because I haven't noticed, when it was "broken".

          In fact it is not a bug. Please pay attention to the plus sign near "trend" at the screenshot:

          If you click on it, then you will see the build log. For ex:

           

          So one can show build history by pressing plus sign or hide it by pressing minus sign.

           

          Best Regards,

          Ilya

          Show
          imdobr Ilya Dobrovolsky added a comment - - edited Hello all. I had the same issue. I was quite confused, because I haven't noticed, when it was "broken". In fact it is not a bug. Please pay attention to the plus sign near "trend" at the screenshot: If you click on it, then you will see the build log. For ex:   So one can show build history by pressing plus sign or hide it by pressing minus sign.   Best Regards, Ilya
          Hide
          afsilva andre silva added a comment -

          I'm also experiencing this issue. Please let me know how I can help you fixing it

          Show
          afsilva andre silva added a comment - I'm also experiencing this issue. Please let me know how I can help you fixing it
          Hide
          maxlehmann max lehmann added a comment -

          Well, this is frustrating. Build history was missing yesterday, but this morning it's back. Which is good, but doesn't help us to diagnose the issue.

          As I recall there was nothing interesting around js nor anything useful in the network traffic at the time - when checking this morning the whole area of the page is back so no way to look for useful data for diagnosing the problem.

          I'd like to not close this just yet in case it recurs, at which point I'll chase for more data for you.

          Show
          maxlehmann max lehmann added a comment - Well, this is frustrating. Build history was missing yesterday, but this morning it's back. Which is good, but doesn't help us to diagnose the issue. As I recall there was nothing interesting around js nor anything useful in the network traffic at the time - when checking this morning the whole area of the page is back so no way to look for useful data for diagnosing the problem. I'd like to not close this just yet in case it recurs, at which point I'll chase for more data for you.
          Hide
          danielbeck Daniel Beck added a comment -

          I don't have access to logs or command line access on our Jenkins installation, but may be able to get assistance get that if it will help fix the issue.

          Without at least the Jenkins log output, this issue cannot be investigated. Get help from your Jenkins admin, and ask them to provide the logs at the /log/all URL.

          Also, anything interesting in your browser's script console/JS error log?

          Show
          danielbeck Daniel Beck added a comment - I don't have access to logs or command line access on our Jenkins installation, but may be able to get assistance get that if it will help fix the issue. Without at least the Jenkins log output, this issue cannot be investigated. Get help from your Jenkins admin, and ask them to provide the logs at the /log/all URL. Also, anything interesting in your browser's script console/JS error log?

            People

            • Assignee:
              maxlehmann max lehmann
              Reporter:
              maxlehmann max lehmann
            • Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: