Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38834

Freestyle jobs hang in 2.19.1 on Windows 10 Nodes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: core, perforce-plugin
    • Labels:
    • Environment:
      Jenkins 2.19.1 on Ubuntu 14.04 x64
      Windows 10 (1607) Connected via JNLP
    • Similar Issues:

      Description

      Freestyle jobs hang either at the beginning or the end of execution. I've let a few run for ~18 hours before they eventually crash with errors like these:

      07:52:37 java.io.IOException: Unable to get hostname from slave. null
      07:52:37              at hudson.plugins.perforce.PerforceSCM.checkout(PerforceSCM.java:1187)
      07:52:37              at hudson.model.AbstractProject.checkout(AbstractProject.java:1278)
      07:52:37              at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
      07:52:37              at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      07:52:37              at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
      07:52:37              at hudson.model.Run.execute(Run.java:1720)
      07:52:37              at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      07:52:37              at hudson.model.ResourceController.execute(ResourceController.java:98)
      07:52:37              at hudson.model.Executor.run(Executor.java:404)
      

      Reverting back to Jenkins 2.7.4 immediately resolved the issue. Issue was not observed with any Linux/OSX/older Windows nodes.

        Attachments

          Issue Links

            Activity

            ejpenney Emory Penney added a comment -

            That appears to be the case, all affected nodes are Win10 AE, but not all of my Win10 AE nodes are affected. It doesn't look like the affliction is consistent: Sometimes jobs will run fine on these nodes, sometimes they won't.

            gregcovertsmith Greg Smith added a comment -

            I believe the difference between my environment (where this hang causes all builds to stall) and your environment (where only that single node stalls) - is that we are using Pipeline builds, where you are using freestyle builds.

            As part of the code for a pipeline build runs on the master, this hang seems to block all other activity on the master. That makes it a bit worse in the scenario where Pipeline is being used – but either way, its very bad.

            gregcovertsmith Greg Smith added a comment -

            We were able to recreate this problem with per-anniversary edition of Windows 10, so its not related to that.

            It looks like this might be related to https://issues.jenkins-ci.org/browse/JENKINS-19445

            ejpenney Emory Penney added a comment -

            I tried 2.32.3 with Oracle JDK8 today, issue persists.

            ejpenney Emory Penney added a comment -

            It looks like upgrading my master to Ubuntu 16.04 resolved this issue.  It was a fresh build, so it's possible Jenkins upgrades left some garbage in a config file somewhere, and my clean build didn't have that issue?  Anyways, the issue is resolved for me, but it looks like people on certain configs/following certain upgrade paths may still have this issue.


              People

              • Assignee:
                Unassigned
                Reporter:
                ejpenney Emory Penney
              • Votes:
                1 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: