Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39006

Build does not trigger with Inverse strategy and Github plugin trigger enabled

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Environment:
    • Similar Issues:
    • Epic Link:

      Description

      The Job configured with "Inverse" strategy and triggered when a push to Github stops working after I upgraded Jenkins from 1.625.3 to 2.19.1 LTS where the git plugin was upgraded to 3.0.0

      The previous settings:
      Git plugin : 2.4.4
      Git client plugin: 1.19.6
      Git server plugin: 1.6
      GitHub API plugin: 1.72
      GitHub plugin: 1.17.1
      GitHub Pull Request Builder: 1.31.2

      works fine with Inverse strategy and GitHub trigger.

      The jenkins log shows the Github webhook is triggered and the job is poked:

      Oct 14, 2016 2:49:43 PM org.jenkinsci.plugins.github.webhook.subscriber.DefaultPushGHEventSubscriber onEvent
      INFO: Received POST for https://cto-github.cisco.com/NFV-BU/github-demo
      Oct 14, 2016 2:49:43 PM org.jenkinsci.plugins.github.webhook.subscriber.DefaultPushGHEventSubscriber$1 run
      INFO: Poked Rally-Github-Jenkins-Integration ยป github-demo-build

      However, the build never triggers.

      -Indra

        Attachments

          Issue Links

            Activity

            ingunawa Indra Gunawan added a comment - - edited

            I downgraded git plugin to version 2.4.4 and git client to 1.19.7 but the inverse strategy still is not working even though I now use SCM polling.

            Regular SCM Polling with default works fine.

            Somehow after either upgrading to 2.7.4 LTS with pipelines and github organization, and CloudBees Folders upgraded, or further upgrade to 2.19.1 LTS then cause this regression issue.

            Now I am getting this in the Jenkins log:

            Oct 20, 2016 6:25:01 AM jenkins.plugins.git.AbstractGitSCMSource getCacheDir
            INFO: Failed mkdirs of /opt/nmtgre-tools/jenkins/conf/caches

            Why it can't create caches directory or write to it? Is this git plugin?

            ingunawa Indra Gunawan added a comment -

            It looks like I need to enable "Force polling using workspace".
            I am now successful to use "Inverse" Strategy to build non-master branch upon commit push to Github.

            The git plugin I use is version 2.5.1 and git-client version 1.19.7.

            Reference: https://issues.jenkins-ci.org/browse/JENKINS-10131 and https://issues.jenkins-ci.org/browse/JENKINS-21264

            -Indra

            ingunawa Indra Gunawan added a comment -

            Closing this as duplicate


              People

              • Assignee:
                Unassigned
                Reporter:
                ingunawa Indra Gunawan
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: