Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39219

Pipeline from SCM options disappear

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Jenkins 2.19.1
      Java 1.8.0_101
      Pipeline 2.4
    • Similar Issues:

      Description

      When I create a new Pipeline job, there are 5 options for the build step Pipeline script from SCM (None, CVS, CVS Projectset, Git, Subversion). After I save the new job, when I go to Configure, some of the options disappear.

      Steps:

      1. Create a new Pipeline job
      2. Set Pipeline script from SCM to None
      3. Save the job
      4. Configure the job

      EXPECTED: None is still selected
      BUG: None and other options are removed from the list

      Complete list of Pipeline plugins in use

      Pipeline 2.4
      Pipeline Graph Analysis Plugin 1.2			
      Pipeline: API  2.5
      Pipeline: Basic Steps 2.2	
      Pipeline: Build Step 2.3	
      Pipeline: Groovy 2.21
      Pipeline: Input Step 2.3	
      Pipeline: Job 2.7	
      Pipeline: Milestone Step 1.1	
      Pipeline: Multibranch 2.9	
      Pipeline: Nodes and Processes 2.5	
      Pipeline: REST API Plugin 2.1	
      Pipeline: SCM Step 2.2	
      Pipeline: Shared Groovy Libraries 2.4	
      Pipeline: Stage Step 2.2	
      Pipeline: Stage View Plugin 2.1	
      Pipeline: Step API 2.4	
      

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Actually the bug, if it is indeed reproducible, is that the inappropriate options (SCMs not yet compatible with Pipeline, and None) are offered the first time. StaplerReferer hack not working, perhaps.

            smd Stefan Drissen added a comment - - edited

            Using 2.45 and all plug-ins updated to latest on Windows 10.

            I have the same issue with Team Foundation Version Control (TFVC) - it is shown as SCM option (None / GIT / TFVC) with all the valid options for TFVC when creating the pipeline.

            Building fails with:

            java.lang.AbstractMethodError: you must override the new overload of checkout
            	at hudson.scm.SCM.checkout(SCM.java:489)
            	at org.jenkinsci.plugins.workflow.steps.scm.SCMStep.checkout(SCMStep.java:109)
            	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:108)
            	at org.jenkinsci.plugins.workflow.cps.CpsScmFlowDefinition.create(CpsScmFlowDefinition.java:57)
            	at org.jenkinsci.plugins.workflow.job.WorkflowRun.run(WorkflowRun.java:215)
            	at hudson.model.ResourceController.execute(ResourceController.java:98)
            	at hudson.model.Executor.run(Executor.java:405)
            Finished: FAILURE
            

            Reopening the pipeline shows Git as only valid SCM option.

            karanva Karolina Arancibia Valuskova added a comment -

            was this actually solved? I run into the same issue in version 2.176.1

            talz tal z added a comment - - edited

            same problem here....

            version 2.176.1

            talz tal z added a comment -

            Karolina Arancibia Valuskova , did you solve it by downgrade to lower jenkins version?

            Thanks

            karanva Karolina Arancibia Valuskova added a comment -

            tal z no, as a work around I change the pipeline > definition to: **pipeline script. Save. Then change again to pipeline script from SCM, and then the SCM options are back. it is a bit of a pain, but since we are planning to use a repository in the future, it is not a big issue for us. Hope that helps until this is fixed.


              People

              • Assignee:
                Unassigned
                Reporter:
                cwcam Cam Spencer
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: