Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39304

Claim Plugin: WorkflowRun cannot be cast to AbstractBuild

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: claim-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.651.2, Pipeline 2.4 Plugin, Build Failure Analyzer Plugin 1.17.1, Claim Plugin 2.8
    • Similar Issues:

      Description

      When claiming a build that resulted from a Pipeline, a class cast exception is raised if (and only if) the "Error" Dropdown is filled with a value from the Build Failure Analyzer plugin.

      Full stack trace attached.

      Caused by: java.lang.ClassCastException: org.jenkinsci.plugins.workflow.job.WorkflowRun cannot be cast to hudson.model.AbstractBuild
      	at hudson.plugins.claim.ClaimBuildFailureAnalyzer.createFailAction(ClaimBuildFailureAnalyzer.java:57)
      	at hudson.plugins.claim.AbstractClaimBuildAction.doClaim(AbstractClaimBuildAction.java:88)
      

        Attachments

          Activity


            People

            • Assignee:
              greybird Arnaud TAMAILLON
              Reporter:
              ahus1 Alexander Schwartz
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: