Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39330

Grails Plugin doesn't support ex. Conditional BuildStep Plugin

    Details

    • Similar Issues:

      Description

      As illustrated by the attached screenshots, the Grails Plugin doesn't show up in the available choices for the Conditional BuildStep Plugin.

      The Conditional BuildStep Plugin wiki proposes the following approach to ensure a builder plugin is compatible:
      If you're not able to add the builder of your choice within a conditional build step (because it's not available within the dropdown), then this is likely because the builder does not provide a @DataBoundConstructor constructor and/or the Descriptor does not extend hudson.tasks.BuildStepDescriptor...

      As far as I can tell, hudson.tasks.BuildStepDescriptor has been available since Jenkins v1.150.
      And org.kohsuke.stapler.DataBoundConstructor has been available in stapler since Mar 6, 2012.

      So hopefully it's not a big change

        Attachments

          Activity

          Hide
          dlehammer Daniel Hammer added a comment - - edited

          Known workaround: duplicate complete grails setup in ex. "Execute shell" in-order to run conditional Grails build.

          Show
          dlehammer Daniel Hammer added a comment - - edited Known workaround: duplicate complete grails setup in ex. "Execute shell" in-order to run conditional Grails build.

            People

            • Assignee:
              jeffg2one jeffg2one
              Reporter:
              dlehammer Daniel Hammer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: