Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39351

Console logging does not display at runtime

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Won't Fix
    • Component/s: core, robot-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.19.1, Robot Framework plugin 1.6.4
    • Similar Issues:

      Description

      Using keyword Log to Console with parameter no_newline set to True is not working properly in Jenkins. It is not showing anything on console unless new line is sent. I think this is related to https://github.com/robotframework/ride/issues/1217. It was fixed in Robot and I can see it working when running tests from command line.

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          Jenkins core implements line-by-line log processing on agents. It is an as designed behavior since it is the only way to implement reliable password masking and console annotations. IMHO not a defect

          aleksisimell Aleksi Simell added a comment -

          This is not an issue in the plugin, but rather how RF and Jenkins work together. Please reopen if we are mistaken.


            People

            • Assignee:
              jpiironen jpiironen
              Reporter:
              mario_p Mariusz Piliszek
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: