Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39545

Cannot add credentials despite having permissions inside a Folder

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: credentials-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.7.3
      credentials-plugin 2.1.8
      cloudbees-folder 5.13
    • Similar Issues:

      Description

      Issue

      I have a user that does not have Credentials/* permission at root level. This user has all the Job/* and Credentials/* permission under a specific folder.

      In the job configuration, this user is not able to add credentials as the Add button is disabled.

      Example shows with Subversion, but same happens for other plugins (Git, Mercurial, SSH Agent, ...)

      Workaround

      With these permission, this user is able to browse to the Folder Credentials store and add credentials.

        Attachments

          Issue Links

            Activity

            allan_burdajewicz Allan BURDAJEWICZ created issue -
            allan_burdajewicz Allan BURDAJEWICZ made changes -
            Field Original Value New Value
            Description h3. Issue

            I have a user that does not have _Credentials/\*_ permission at root level. This user has all the _Job/\*_ and _Credentials/\*_ permission under *FolderA*.

            In the job configuration, this user is not able to add credentials as the *Add button is disabled*.

            !not-admin-add-disabled.png|thumbnail!

            Example shows with Subversion, but same happens for other plugins (Git, Mercurial, SSH Agent, ...)

            h3. Workaround

            With these permission, this user is able to browse to the Folder Credentials store and add credentials.

            !not-admin-folder-store.png|thumbnail!
            h3. Issue

            I have a user that does not have _Credentials/\*_ permission at root level. This user has all the _Job/\*_ and _Credentials/\*_ permission under a specific folder.

            In the job configuration, this user is not able to add credentials as the *Add button is disabled*.

            !not-admin-add-disabled.png|thumbnail!

            Example shows with Subversion, but same happens for other plugins (Git, Mercurial, SSH Agent, ...)

            h3. Workaround

            With these permission, this user is able to browse to the Folder Credentials store and add credentials.

            !not-admin-folder-store.png|thumbnail!
            stephenconnolly Stephen Connolly made changes -
            Link This issue duplicates JENKINS-35553 [ JENKINS-35553 ]
            stephenconnolly Stephen Connolly made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Duplicate [ 3 ]
            allan_burdajewicz Allan BURDAJEWICZ added a comment -

            I think that this is rather duplicated by JENKINS-41478 than a duplicate of JENKINS-35553

            allan_burdajewicz Allan BURDAJEWICZ made changes -
            Link This issue is duplicated by JENKINS-41478 [ JENKINS-41478 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-1625 (Web Link)" [ 18622 ]

              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                allan_burdajewicz Allan BURDAJEWICZ
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: