Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cvs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:
      Show 5 results

      Description

      After an update to version 1.314 CVS checkout is broken After returning to
      version 1.311 everything works fine as usual )

      Console output as follows:
      [workspace] $ cvs -Q -z3 -d :pserver:user:password@host:/export/rep/hh/mkp co -P
      -D "Friday, July 3, 2009 12:12:31 PM UTC" JSch JZlib MkpTTLibSrc MkpTTLibSrcTest
      MkpTTLoadTool MkpTTTools MkpTTVendor SSHTools MkpDrivers
      $ computing changelog
      cvs server: Logging JSch
      cvs server: Logging JSch/download
      cvs server: Logging JSch/jsch-0.1.30
      cvs server: Logging JSch/jsch-0.1.30/examples
      cvs server: Logging JSch/jsch-0.1.30/src
      cvs server: Logging JSch/jsch-0.1.30/src/com
      cvs server: Logging JSch/jsch-0.1.30/src/com/jcraft
      cvs server: Logging JSch/jsch-0.1.30/src/com/jcraft/jsch
      cvs server: Logging JSch/jsch-0.1.30/src/com/jcraft/jsch/jce
      cvs server: Logging JSch/jsch-0.1.30/src/com/jcraft/jsch/jcraft
      cvs server: Logging JSch/jsch-0.1.30/src/com/jcraft/jsch/jgss
      cvs server: Logging JSch/jsch-0.1.30/tools
      cvs server: Logging JSch/jsch-0.1.30/tools/bin
      cvs server: Logging JZlib
      cvs server: Logging JZlib/download
      cvs server: Logging JZlib/jzlib-1.0.7
      cvs server: Logging JZlib/jzlib-1.0.7/example
      cvs server: Logging JZlib/jzlib-1.0.7/misc
      cvs server: Logging JZlib/jzlib-1.0.7/src
      cvs server: Logging JZlib/jzlib-1.0.7/src/com
      cvs server: Logging JZlib/jzlib-1.0.7/src/com/jcraft
      cvs server: Logging JZlib/jzlib-1.0.7/src/com/jcraft/jzlib
      cvs server: Logging MkpTTLibSrc
      cvs server: Logging MkpTTLibSrc/ant-1.6.3
      cvs server: Logging MkpTTLibSrc/dbunit-2.1
      cvs server: Logging MkpTTLibSrc/httpunit-1.6
      cvs server: Logging MkpTTLibSrc/jconfig-2.8.5
      cvs server: Logging MkpTTLibSrc/junit-3.8.1
      cvs server: Logging MkpTTLibSrc/log4j
      cvs server: Logging MkpTTLibSrc/regexp-1.3
      cvs server: Logging MkpTTLibSrc/webscarab
      cvs server: Logging MkpTTLibSrcTest
      cvs server: Logging MkpTTLibSrcTest/junit-3.8.1
      cvs server: Logging MkpTTLoadTool
      cvs server: Logging MkpTTLoadTool/lib
      cvs server: Logging MkpTTLoadTool/lib/dbunit
      cvs server: Logging MkpTTLoadTool/lib/jConfig
      cvs server: Logging MkpTTLoadTool/src
      cvs server: Logging MkpTTLoadTool/src/de
      cvs server: Logging MkpTTLoadTool/src/de/ppi
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis/ecstasy
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis/ecstasy/tools
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis/ecstasy/tools/dbproxy
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis/mkp
      cvs server: Logging MkpTTLoadTool/src/de/ppi/fis/mkp/stressload
      cvs server: Logging MkpTTTools
      cvs server: Logging MkpTTTools/.settings
      cvs server: Logging MkpTTTools/lib
      cvs server: Logging MkpTTTools/lib/ant
      cvs server: Logging MkpTTTools/lib/db2
      cvs server: Logging MkpTTTools/lib/oracle
      cvs server: Logging MkpTTTools/lib/regexp
      cvs server: Logging MkpTTTools/lib/webscarab
      cvs server: Logging MkpTTTools/libsrc
      cvs server: Logging MkpTTTools/src
      cvs server: Logging MkpTTTools/src/de
      cvs server: Logging MkpTTTools/src/de/ppi
      cvs server: Logging MkpTTTools/src/de/ppi/fis
      cvs server: Logging MkpTTTools/src/de/ppi/fis/ecstasy
      cvs server: Logging MkpTTTools/src/de/ppi/fis/ecstasy/tools
      cvs server: Logging MkpTTTools/src/de/ppi/fis/ecstasy/tools/db
      cvs server: Logging MkpTTTools/src/de/ppi/fis/ecstasy/tools/dbunit
      cvs server: Logging MkpTTTools/src/de/ppi/fis/ecstasy/tools/proxy
      cvs server: Logging MkpTTVendor
      cvs server: Logging MkpTTVendor/.settings
      cvs server: Logging MkpTTVendor/lib
      cvs server: Logging MkpTTVendor/lib/httpunit
      cvs server: Logging MkpTTVendor/lib/jexcel
      cvs server: Logging MkpTTVendor/lib/log4j
      cvs server: Logging MkpTTVendor/lib/xmlsec
      cvs server: Logging MkpTTVendor/libsrc
      cvs server: Logging MkpTTVendor/properties
      cvs server: Logging MkpTTVendor/scripts
      cvs server: Logging MkpTTVendor/src
      cvs server: Logging MkpTTVendor/src/de
      cvs server: Logging MkpTTVendor/src/de/ppi
      cvs server: Logging MkpTTVendor/src/de/ppi/fis
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/presentation
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/presentation/portalintegration
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/adaption
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/cmdline
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/crmstub
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/crmstub/data
      cvs server: nothing known about FAIL-LöscheKunde-12344567890.xml
      cvs server: nothing known about LöscheKunde-12344567890.xml
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/data
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/data/excel
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/data/excel/collectors
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/data/excel/common
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/data/excel/converters
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/ablage
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/at
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/at/AF401
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/ebil
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/export
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/report
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/http/upload
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/siimport
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/common
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/db
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/gui
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/si
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/si/base
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/si/batch
      cvs server: Logging
      MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/si/onlineaktualisierung
      cvs server: Logging
      MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/si/portalintegration
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/test/suite
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/testdata
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/test/vendor/testdata/excel
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/vendor
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkp/vendor/utils
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkpref
      cvs server: Logging MkpTTVendor/src/de/ppi/fis/mkpref/crmstub
      cvs server: Logging MkpTTVendor/testdata
      cvs server: Logging MkpTTVendor/testdata/HomeVerzeichnis
      cvs server: Logging MkpTTVendor/testdata/Referenzumgebung
      cvs server: Logging MkpTTVendor/testdata/attributeConfig
      cvs server: Logging MkpTTVendor/testdata/attributeConfig/Referenzumgebung
      cvs server: Logging MkpTTVendor/testdata/attributeConfig/siOnlineAktualisierung
      cvs server: Logging MkpTTVendor/testdata/cmdline
      cvs server: Logging MkpTTVendor/testdata/db
      cvs server: Logging MkpTTVendor/testdata/ebil
      cvs server: Logging MkpTTVendor/testdata/excel
      cvs server: Logging MkpTTVendor/testdata/lasttest
      cvs server: Logging MkpTTVendor/testdata/lasttest/Lasttest-Ansichten
      cvs server: Logging MkpTTVendor/testdata/lasttest/Lasttest-Kunden
      cvs server: Logging MkpTTVendor/testdata/mask
      cvs server: Logging MkpTTVendor/testdata/rules
      cvs server: Logging MkpTTVendor/testdata/rules/csv
      cvs server: Logging MkpTTVendor/testdata/rules/rules
      cvs server: Logging MkpTTVendor/testdata/siOnlineAktualisierung
      cvs server: Logging MkpTTVendor/testdata/siimport
      cvs server: Logging MkpTTVendor/testdata/upload
      cvs server: Logging SSHTools
      cvs server: Logging SSHTools/src
      cvs server: Logging SSHTools/src/de
      cvs server: Logging SSHTools/src/de/ppi
      cvs server: Logging SSHTools/src/de/ppi/fis
      cvs server: Logging SSHTools/src/de/ppi/fis/sshtools
      cvs server: Logging SSHTools/src/de/ppi/fis/test
      cvs server: Logging SSHTools/src/de/ppi/fis/test/sshtools
      cvs server: Logging MkpDrivers
      cvs server: Logging MkpDrivers/lib
      ERROR: cvs exited with error code 1
      Command line was [Executing 'cvs' with arguments:
      '-d:pserver:user:password@host:/export/rep/hh/mkp'
      'log'
      '-d'
      '>=2009-07-02'
      'JSch'
      'JZlib'
      'MkpTTLibSrc'
      'MkpTTLibSrcTest'
      'MkpTTLoadTool'
      'MkpTTTools'
      'MkpTTVendor'
      'SSHTools'
      'MkpDrivers'

      The ' characters around the executable and arguments are
      not part of the command.
      ] in D:\work\hudson\jobs\MKP-Herstellertest gegen Nightly Build\workspace
      Input text:
      START==>null<==END
      Working directory is D:\work\hudson\jobs\MKP-Herstellertest gegen Nightly
      Build\workspace
      cvs exited with error code 1
      Command line was [Executing 'cvs' with arguments:
      '-d:pserver:user:password@host:/export/rep/hh/mkp'
      'log'
      '-d'
      '>=2009-07-02'
      'JSch'
      'JZlib'
      'MkpTTLibSrc'
      'MkpTTLibSrcTest'
      'MkpTTLoadTool'
      'MkpTTTools'
      'MkpTTVendor'
      'SSHTools'
      'MkpDrivers'

      The ' characters around the executable and arguments are
      not part of the command.
      ] in D:\work\hudson\jobs\MKP-Herstellertest gegen Nightly Build\workspace
      Input text:
      START==>null<==END
      at
      hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.runCommand(AbstractCvsTask.java:387)
      at
      hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.execute(AbstractCvsTask.java:457)
      at
      hudson.org.apache.tools.ant.taskdefs.cvslib.ChangeLogTask.execute(ChangeLogTask.java:293)
      at hudson.scm.CVSSCM$4.invoke(CVSSCM.java:892)
      at hudson.scm.CVSSCM$4.invoke(CVSSCM.java:827)
      at hudson.FilePath.act(FilePath.java:649)
      at hudson.FilePath.act(FilePath.java:633)
      at hudson.scm.CVSSCM.calcChangeLog(CVSSCM.java:827)
      at hudson.scm.CVSSCM.checkout(CVSSCM.java:396)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:830)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:314)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:266)
      at hudson.model.Run.run(Run.java:938)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:118)

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          When you run the same command from command line, do you get any error message?

          m31 m31 added a comment -

          running the following lead to"Can't parse date/time: JSch" because of the ">":
          cvs -d:pserver:user:password@host:/export/rep/hh/mkp log -d >=2009-07-02 JSch
          JZlib MkpTTLibSrc MkpTTLibSrcTest MkpTTLoadTool MkpTTTools MkpTTVendor SSHTools
          MkpDrivers

          runs ok:
          cvs -d:pserver:user:password@host:/export/rep/hh/mkp log -d ">=2009-07-02" JSch
          JZlib MkpTTLibSrc MkpTTLibSrcTest MkpTTLoadTool MkpTTTools MkpTTVendor SSHTools
          MkpDrivers

          How is the command line tool called?

          m31 m31 added a comment -

          so now I tested it again with 1.315, 1.314 and 1.311:
          even working on a wiped out workspace 1.315 and 1.314 fail!

          for me it looks like an encoding problem, because updating with different
          versions lead to different warnings:

          cvs server: warning:
          src/de/ppi/fis/mkp/test/vendor/crmstub/data/LöscheKunde-12344567890.xml is not
          (any longer) pertinent

          cvs update: move away
          src/de/ppi/fis/mkp/test/vendor/crmstub/data/FAIL-LöscheKunde-12344567890.xml; it
          is in the way

          Checking out works under 1.315, but computing the changelog fails.

          azgard azgard added a comment -

          I think also, that is the problem. We have also files with german umlauts and
          the build is on this projects broken today.

          I hope this will fixed soon.

          Thanx for yout work, guys.

          azgard azgard added a comment -

          This is the same error as reported in #2614.

              • This issue has been marked as a duplicate of 2614 ***
          azgard azgard added a comment -

          Please update your votes!

          m31 m31 added a comment -

          But we worked with hudson version 1.311 without problems, but switching to
          version 1.314 or 1.315 lead to failures.

          So the question is: was issue 2614 also solved in 1.311? If not it is another
          problem.

          m31 m31 added a comment -

          To me it's still a new problem.

          lbeuster lbeuster added a comment -

          Perhaps this is a duplicate of #2614, but this bug was introduced in 1.314 with
          the "improvement" for making hudson more robust in parsing CVS/Entries (
          http://www.nabble.com/Exception-while-checking-out-from-CVS-td24256117.html).
          #2614 exists since 11/2008.

          It seems to me that one problem is fixed and another - more critical - problem
          was introduced.

          Ant it prevents me from upgrading to a newer version than 1.313.

          dadoonet95 dadoonet95 added a comment -

          I get the same issue with version 1.318.

          at
          hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.runCommand(AbstractCvsTask.java:387)

          When I do the cvs command manually, I get the changelog normally.

          cvs -d:pserver:login:passwd@cvserver:/home/cvs log -d '>=2009-08-04'

          I return to a previous version (1.309)...

          Thanks...

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in hudson
          User: : kohsuke
          Path:
          trunk/hudson/main/core/src/main/java/hudson/scm/CVSSCM.java
          trunk/hudson/main/core/src/main/java/hudson/util/AtomicFileWriter.java
          trunk/www/changelog.html
          http://fisheye4.cenqua.com/changelog/hudson/?cs=20488
          Log:
          [FIXED JENKINS-3979] in 1.320. Hudson was writing back CVS/Entries in a wrong encoding.

          dadoonet95 dadoonet95 added a comment -

          I tried this morning the 1.320-SNAPSHOT version and i've got again the same error.

          Is the bug really fixed in the 1.320 version ? Am i doing something wrong ?

          Thanks,
          David.

          Input text:
          START==>null<==END
          at
          hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.runCommand(AbstractCvsTask.java:387)
          at
          hudson.org.apache.tools.ant.taskdefs.AbstractCvsTask.execute(AbstractCvsTask.java:457)
          at
          hudson.org.apache.tools.ant.taskdefs.cvslib.ChangeLogTask.execute(ChangeLogTask.java:293)

          dadoonet95 dadoonet95 added a comment -

          The bug is fixed with the 1.320 version.
          Thanks for the release

          andreasleue andreasleue added a comment -

          The problem seems still not (completely) fixed.
          I've just upgraded to 1.321 from 318
          OS linux
          Problem is as follows:
          after checkout, workspace is ok
          then, when checking log, hudson rewrites CVS/Entries:
          a file name with eg. german umlaut in latin1 encoding is then rewritten to utf8
          encoding
          the log checking then succeeds
          but afterwards, next checkout fails, since cvs gets confused

          andreasleue andreasleue added a comment -

          to be more precise:
          "cvs gets confused" means, at next checkout, it does not find the file in
          CVS/Entries due to the wrong encoding, wants to check it out then, but sees the
          file already exists in the file system and then complains about this and fails

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: mc1arke
          Path:
          pom.xml
          src/main/java/hudson/org/apache/tools/ant/taskdefs/AbstractCvsTask.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/CVSEntry.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/ChangeLogParser.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/ChangeLogTask.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/ChangeLogWriter.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/CvsUser.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/RCSFile.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/RedirectingOutputStream.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/RedirectingStreamHandler.java
          src/main/java/hudson/org/apache/tools/ant/taskdefs/cvslib/package.html
          src/main/java/hudson/scm/CVSChangeLogParser.java
          src/main/java/hudson/scm/CVSChangeLogSet.java
          src/main/java/hudson/scm/CVSRepositoryBrowser.java
          src/main/java/hudson/scm/CVSSCM.java
          src/main/java/hudson/scm/CvsChangeLogHelper.java
          src/main/java/hudson/scm/CvsChangeSet.java
          src/main/java/hudson/scm/CvsFile.java
          src/main/java/hudson/scm/CvsModule.java
          src/main/java/hudson/scm/CvsModuleLocation.java
          src/main/java/hudson/scm/CvsModuleLocationType.java
          src/main/java/hudson/scm/CvsRepository.java
          src/main/java/hudson/scm/CvsRevisionState.java
          src/main/java/hudson/scm/ExcludedRegion.java
          src/main/java/hudson/scm/LegacyConvertor.java
          src/main/java/hudson/scm/MailAddressResolverImpl.java
          src/main/java/hudson/scm/cvstagging/CvsTagAction.java
          src/main/java/hudson/scm/cvstagging/CvsTagActionDescriptor.java
          src/main/java/hudson/scm/cvstagging/CvsTagActionWorker.java
          src/main/java/hudson/scm/cvstagging/LegacyTagAction.java
          src/main/resources/hudson/scm/CVSSCM/DescriptorImpl/enterPassword.jelly
          src/main/resources/hudson/scm/CVSSCM/DescriptorImpl/versionCheckError.jelly
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_de.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_fr.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_ja.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_nl.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_ru.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/help-tagAll_tr.html
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm.jelly
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_de.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_es.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_fr.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_ja.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_nl.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_pt_BR.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_ru.properties
          src/main/resources/hudson/scm/CVSSCM/TagAction/tagForm_tr.properties
          src/main/resources/hudson/scm/CVSSCM/config.jelly
          src/main/resources/hudson/scm/CVSSCM/config.properties
          src/main/resources/hudson/scm/CVSSCM/global.jelly
          src/main/resources/hudson/scm/CVSSCM/help-allModules.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_de.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_nl.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_ru.html
          src/main/resources/hudson/scm/CVSSCM/help-allModules_tr.html
          src/main/resources/hudson/scm/CVSSCM/help-branch.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_de.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_nl.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_ru.html
          src/main/resources/hudson/scm/CVSSCM/help-branch_tr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_de.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_nl.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_ru.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_tr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsExe_zh_CN.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_de.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_nl.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_ru.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRoot_tr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_de.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_nl.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_pt_BR.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_ru.html
          src/main/resources/hudson/scm/CVSSCM/help-cvsRsh_tr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvspassFile.html
          src/main/resources/hudson/scm/CVSSCM/help-cvspassFile_de.html
          src/main/resources/hudson/scm/CVSSCM/help-cvspassFile_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-cvspassFile_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-cvspassFile_zh_CN.html
          src/main/resources/hudson/scm/CVSSCM/help-disableCvsQuiet.html
          src/main/resources/hudson/scm/CVSSCM/help-excludedRegions.html
          src/main/resources/hudson/scm/CVSSCM/help-excludedRegions_de.html
          src/main/resources/hudson/scm/CVSSCM/help-excludedRegions_fr.html
          src/main/resources/hudson/scm/CVSSCM/help-excludedRegions_ja.html
          src/main/resources/hudson/scm/CVSSCM/help-pruneEmptyDirectories.html
          src/main/resources/hudson/scm/CVSSCM/help-skipChangeLog.html
          src/main/resources/hudson/scm/CVSSCM/help-useHeadIfNotFound.html
          src/main/resources/hudson/scm/CVSSCM/help-useHeadIfNotFound_de.html
          src/main/resources/hudson/scm/CvsModule/config.jelly
          src/main/resources/hudson/scm/CvsModule/config.properties
          src/main/resources/hudson/scm/CvsModule/config_de.properties
          src/main/resources/hudson/scm/CvsModule/config_es.properties
          src/main/resources/hudson/scm/CvsModule/config_fr.properties
          src/main/resources/hudson/scm/CvsModule/config_ja.properties
          src/main/resources/hudson/scm/CvsModule/config_nl.properties
          src/main/resources/hudson/scm/CvsModule/config_pt_BR.properties
          src/main/resources/hudson/scm/CvsModule/config_ru.properties
          src/main/resources/hudson/scm/CvsModule/config_tr.properties
          src/main/resources/hudson/scm/CvsModule/help-branchName.html
          src/main/resources/hudson/scm/CvsModule/help-localName.html
          src/main/resources/hudson/scm/CvsModule/help-remoteName.html
          src/main/resources/hudson/scm/CvsModule/help-tagName.html
          src/main/resources/hudson/scm/CvsModule/help-useHeadIfNotFound.html
          src/main/resources/hudson/scm/CvsModule/help-useHeadIfNotFound_de.html
          src/main/resources/hudson/scm/CvsModuleLocation/BranchModuleLocation/config.jelly
          src/main/resources/hudson/scm/CvsModuleLocation/HeadModuleLocation/config.jelly
          src/main/resources/hudson/scm/CvsModuleLocation/TagModuleLocation/config.jelly
          src/main/resources/hudson/scm/CvsRepository/config.jelly
          src/main/resources/hudson/scm/CvsRepository/config.properties
          src/main/resources/hudson/scm/CvsRepository/config_de.properties
          src/main/resources/hudson/scm/CvsRepository/config_es.properties
          src/main/resources/hudson/scm/CvsRepository/config_fr.properties
          src/main/resources/hudson/scm/CvsRepository/config_ja.properties
          src/main/resources/hudson/scm/CvsRepository/config_nl.properties
          src/main/resources/hudson/scm/CvsRepository/config_pt_BR.properties
          src/main/resources/hudson/scm/CvsRepository/config_ru.properties
          src/main/resources/hudson/scm/CvsRepository/config_tr.properties
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_de.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_fr.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_ja.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_nl.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_pt_BR.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_ru.html
          src/main/resources/hudson/scm/CvsRepository/help-cvsRoot_tr.html
          src/main/resources/hudson/scm/CvsRepository/help-excludedRegions.html
          src/main/resources/hudson/scm/CvsRepository/help-excludedRegions_de.html
          src/main/resources/hudson/scm/CvsRepository/help-excludedRegions_fr.html
          src/main/resources/hudson/scm/CvsRepository/help-excludedRegions_ja.html
          src/main/resources/hudson/scm/ExcludedRegion/config.jelly
          src/main/resources/hudson/scm/cvs/Messages.properties
          src/main/resources/hudson/scm/cvs/Messages_de.properties
          src/main/resources/hudson/scm/cvs/Messages_es.properties
          src/main/resources/hudson/scm/cvs/Messages_fr.properties
          src/main/resources/hudson/scm/cvs/Messages_ja.properties
          src/main/resources/hudson/scm/cvs/Messages_nl.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_de.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_fr.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_ja.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_nl.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_pt_BR.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_ru.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/help-tagAll_tr.html
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm.jelly
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_de.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_es.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_fr.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_ja.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_nl.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_pt_BR.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_ru.properties
          src/main/resources/hudson/scm/cvstagging/CvsTagAction/tagForm_tr.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_de.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_fr.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_ja.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_nl.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_pt_BR.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_ru.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/help-tagAll_tr.html
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm.jelly
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_de.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_es.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_fr.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_ja.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_nl.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_pt_BR.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_ru.properties
          src/main/resources/hudson/scm/cvstagging/LegacyTagAction/tagForm_tr.properties
          src/test/java/hudson/scm/CVSSCMTest.java
          src/test/java/hudson/scm/CvsChangeLogHelperTest.java
          http://jenkins-ci.org/commit/cvs-plugin/1c6ddef1e5c1c3fe9f1a236fe4cc3aa336b8ca21
          Log:
          Merge pull request #5 from mc1arke/master

          Overhaul of the cvs plugin

          Changes:

          Potentially also fixes:
          JENKINS-1737: Alternative Quiet Period Implementation (untested - updated polling should fix this)
          JENKINS-10843: CVS Update (defect is unclear)
          JENKINS-427: Cannot check out alias modules from CVS (untested - using rlog should fix this)

          It's probably worth updating the version number in the POM to 2.0 given the number/scale of these changes, although this hasn't been included as part of this request.

          Compare: https://github.com/jenkinsci/cvs-plugin/compare/7b57474...1c6ddef

          mc1arke Michael Clarke added a comment -

          This has been fixed in version 2.0 of the cvs plugin by using rlog for computing the change log, and using a java cvs library (rather than the native O/S library) to manage entries to we don't break the encoding of entries files


            People

            • Assignee:
              mc1arke Michael Clarke
              Reporter:
              m31 m31
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: