Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-39850

Blue Ocean should respect build.displayName

    XMLWordPrintable

    Details

    • Sprint:
      Blue Ocean 1.1-beta4
    • Similar Issues:

      Description

      Scope

      • Show the display name in the messages column of activity
      • Show the display name in the triggered area of the result

      Original request
      Code allows you to set:

      currentBuild.displayName = 'foo'
      

      But Blue ocean does not respect it. Attached: classic and BO views.

        Attachments

          Issue Links

            Activity

            roidelapluie Julien Pivotto created issue -
            roidelapluie Julien Pivotto made changes -
            Field Original Value New Value
            Summary Blue Ocean does not respect displayName Blue Ocean does not respect build.displayName
            roidelapluie Julien Pivotto made changes -
            Issue Type Bug [ 1 ] Improvement [ 4 ]
            roidelapluie Julien Pivotto made changes -
            Summary Blue Ocean does not respect build.displayName Blue Ocean should respect build.displayName
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35750 [ 171713 ]
            jamesdumay James Dumay made changes -
            Sprint tethys [ 161 ]
            jamesdumay James Dumay made changes -
            Assignee Ivan Meredith [ imeredith ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint tethys [ 161 ] kraken [ 166 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint kraken [ 166 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Assignee Ivan Meredith [ imeredith ]
            jamesdumay James Dumay made changes -
            Description Code allows you to set:

            {code}
            currentBuild.displayName = 'foo'
            {code}

            But Blue ocean does not respect it. Attached: classic and BO views.
            *Scope*
            * Show the display name in the messages column of activity
            * Show the display name in the triggered area of the result

            *Original request*
            Code allows you to set:

            {code}
            currentBuild.displayName = 'foo'
            {code}

            But Blue ocean does not respect it. Attached: classic and BO views.
            akrapfl Adam Krapfl added a comment -

            +1

            My team also uses currentBuild.description and currentBuild.displayName quite heavily.  It is much more useful to have a version number in the build column than it does a generic number.

            jamesdumay James Dumay made changes -
            Labels pipeline-improvement
            jamesdumay James Dumay added a comment -

            Thanks Adam Krapfl - we are considering this one.

            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2 [ 296 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2 [ 296 ] Blue Ocean 1.3 [ 311 ]
            jamesdumay James Dumay made changes -
            Rank Ranked lower
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-41769 [ JENKINS-41769 ]
            jamesdumay James Dumay made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            jamesdumay James Dumay made changes -
            Resolution Duplicate [ 3 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            jamesdumay James Dumay added a comment -

            Reopened as we can implement JENKINS-41769 pretty quickly but this one requires a bit more effort due to the "Run" column being a bit longer and our tables will need to change.

            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.3 [ 311 ] Blue Ocean 1.1-beta3 [ 316 ]
            jamesdumay James Dumay made changes -
            Status Reopened [ 4 ] In Progress [ 3 ]
            jamesdumay James Dumay made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jamesdumay James Dumay made changes -
            Assignee James Dumay [ jamesdumay ]
            jamesdumay James Dumay added a comment -

            It will look a bit like this


            We may have some troubles on very long display names but that will have to wait until we get our tables updated to the new style. For the moment, we've made it so you can hover to get the full title.

            jamesdumay James Dumay added a comment -

            Will be released in Blue Ocean 1.1

            jamesdumay James Dumay made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            jamesdumay James Dumay made changes -
            Comment [ Merged into JENKINS-41769. Please watch this ticket instead. ]
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35750 [ 171713 ] JENKINS-43952 [ 181484 ]
            jamesdumay James Dumay made changes -
            Issue Type Improvement [ 4 ] Story [ 10002 ]
            bkorren Barak Korren added a comment -

            I don't think this is working properly now.

            We have complex jobs that use displayName heavily. We're explicitly using displayName to be able to quickly look at the list of builds and know which one did what. While the main build screen does show the name in the top of the page, the activity screen does not show it anywhere, not even on mouse hover as mentioned in previous comment on this issue. It just shows the build number.

            Here are example jobs that use displayName heavily (These should be publicly viewable):

            http://jenkins.ovirt.org/job/ovirt-master_change-queue/

            http://jenkins.ovirt.org/job/ovirt-master_change-queue-tester/

             

            It is pretty important for us to see the right display names, otherwise we can't use BlueOcean to monitor these jobs.

            bkorren Barak Korren made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            jamesdumay James Dumay added a comment -

            Please open a new bug with a Jenkinsfile that can reproduce the error, rather than reopen this ticket.

            jamesdumay James Dumay made changes -
            Status Reopened [ 4 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]
            akrapfl Adam Krapfl made changes -
            Attachment image-2017-09-05-15-52-32-861.png [ 39588 ]
            akrapfl Adam Krapfl made changes -
            Attachment image-2017-09-05-15-52-54-781.png [ 39589 ]
            akrapfl Adam Krapfl made changes -
            Attachment image-2017-09-05-15-53-26-554.png [ 39590 ]
            akrapfl Adam Krapfl added a comment -

            James Dumay Barak Korren I see this as still broken as well.  Or rather, partially working:

            the following groovy on blue ocean: 1.2.0 · Core 2.60.3 · 4d42c87 · (no branch) 

            node {
             stage('start') {
             currentBuild.displayName = "foo.$BUILD_NUMBER"
             currentBuild.description = "foo.$BUILD_NUMBER - desc"
             echo 'Hello World'
             }
            }

            produces the attached ui in classic and blue ocean views.

             

             

            akrapfl Adam Krapfl added a comment -

            James Dumay Barak Korren

            Added JENKINS-46657 to track the defect with this feature.


              People

              • Assignee:
                jamesdumay James Dumay
                Reporter:
                roidelapluie Julien Pivotto
              • Votes:
                9 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: