Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40056

CLI fails when JNLP port disabled

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: cli, core
    • Labels:
    • Environment:
      Clean install on:
      CentOS Linux release 7.2.1511
      jenkins-2.33-1.1.noarch
      blueocean 1.0.0-b12
    • Similar Issues:

      Description

      The blueocean plugin install errors at the CLI on a clean / new system (no other plugin on my standard list fail like this, for example, these install just fine: github-oauth and build-pipeline-plugin)

      Repeatable steps on a clean system to reproduce:

      /usr/bin/java -jar /var/cache/jenkins/war/WEB-INF/jenkins-cli.jar -s http://localhost:8080/ install-plugin blueocean -restart --username admin --password blahblahblah

      Results in error:

      SEVERE: I/O error in channel Chunked connection to http://localhost:8080/cli
      java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:73)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2353)
      at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2822)
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:804)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:301)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:59)

      hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.Request.abort(Request.java:307)
      at hudson.remoting.Channel.terminate(Channel.java:888)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:92)
      at ......remote call to Chunked connection to http://localhost:8080/cli(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
      at hudson.remoting.Request.call(Request.java:172)
      at hudson.remoting.Channel.call(Channel.java:821)
      at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:256)
      at com.sun.proxy.$Proxy3.main(Unknown Source)
      at hudson.cli.CLI.execute(CLI.java:332)
      at hudson.cli.CLI._main(CLI.java:503)
      at hudson.cli.CLI.main(CLI.java:384)
      Caused by: java.io.IOException: Unexpected termination of the channel
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:73)
      Caused by: java.io.EOFException
      at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2353)
      at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2822)
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:804)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:301)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:59)

      I have attached the Ansible playbook so you can see the exact build steps.
      This is the line that errors either via playbook or via command line:

      /usr/bin/java -jar /var/cache/jenkins/war/WEB-INF/jenkins-cli.jar -s http://localhost:8080/ install-plugin blueocean -restart --username admin --password blahblahblah

      Note:
      I am able to install other plugins using this same CLI command without issue.

      Question / Thought:
      Am I using a high enough version of Jenkins?

      Here is how/where I am getting Jenkins 2.33 currently via :
      http://pkg.jenkins.io/redhat

        Attachments

          Issue Links

            Activity

            jamesdumay James Dumay added a comment - - edited

            I deleted my jenkins home, setup Jenkins with no plugins, enabled JNLP random setting then ran the cli and I did not see this issue. It seems to be happening with Jenkins JNLP setting disabled (as it is when you setup a fresh Jenkins).

            jglick Jesse Glick added a comment -

            Nothing to do with any particular command, just an issue with using a particular transport, and lousy error reporting.

            Best to stick with the SSH transport IMO.

            jglick Jesse Glick added a comment -

            BTW this sounds really familiar, probably a duplicate.

            oleg_nenashev Oleg Nenashev added a comment -

            Jesse Glick I suppose it is not longer a problem after CLI rework in 2.55, right?

            jglick Jesse Glick added a comment -

            Poor error reporting in a system which is now disabled by default.


              People

              • Assignee:
                Unassigned
                Reporter:
                ernestgwilsonii Ernest G. Wilson II
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: