Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40153

Wrong Jenkins-Version for Git client 1.2x.x (structs dependency)

    Details

    • Similar Issues:

      Description

      For git-client-plugin:1.20.2 and git-client-plugin:1.21.0, Jenkins-Version is 1.532.2

      It should be 1.580.1 according to the dependency to structs:1.3

      This error causes an impossible dependency resolution for Jenkins 1.532.2 to 1.580.1 instances after updating git-client-plugin to 1.2x.x

        Attachments

          Activity

          Hide
          markewaite Mark Waite added a comment -

          You're correct that this is a bug. It will not be fixed.

          Jenkins 1.532 is so old that I no longer perform any testing with it, and won't perform testing with it. Users that need to stay with Jenkins 1.532 (for whatever reason) should also not need to install more recent plugin versions.

          Show
          markewaite Mark Waite added a comment - You're correct that this is a bug. It will not be fixed. Jenkins 1.532 is so old that I no longer perform any testing with it, and won't perform testing with it. Users that need to stay with Jenkins 1.532 (for whatever reason) should also not need to install more recent plugin versions.

            People

            • Assignee:
              markewaite Mark Waite
              Reporter:
              guparan Guillaume Paran
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: