Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40518

Give the unzip step a parameter to suppress verbose output

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
    • Environment:
      Pipeline Utility Steps 1.2.2
      Pipeline 2.4
      Jenkins LTS 2.19.4
      Zulu OpenJDK 1.8.0_102-b14
      Windows 7 Pro
    • Similar Issues:

      Description

      The unzip step logs for every file extracted, which can clutter up the console (similar to JENKINS-14541). It would be nice if it took an argument to reduce verbosity. Maybe just a one-line log message reporting how many files were extracted, after the initial Extracting from: message.

      Currently if I have a big ZIP and do the following

      node {
        unzip( zipFile: 'biggy.zip', dir: 'over/there' )
      }
      

      Then it could yield hundreds of lines after the initial message like

      Extracting: somefile -> c:\jenkins_agent\workspace\cool-job\over\there\somefile
       .
       .
       .
      

        Attachments

          Issue Links

            Activity

            brianeray Brian Ray added a comment -

            Thank you Matthew Brenner.

            ljbd Łukasz Dudek added a comment -

            Thanks a lot, Matthew Brenner!

            madbrenner Matthew Brenner added a comment -

            Roman Baeriswyl thanks for pointing that out! I can confirm the parameter is available and working after updating the plugin to 2.0.

            madbrenner Matthew Brenner added a comment -

            A boolean parameter 'quiet' was added to the unzip step to address this issue in pull request 40.

            This was released in version 2.0, on February 14th, 2018.


              People

              • Assignee:
                rsandell rsandell
                Reporter:
                brianeray Brian Ray
              • Votes:
                4 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: