Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40641

weblogic deployer plugin does not work in Windows OS

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      Windows 7, weblogic 12c, JDK1.6.0_29, Jenkins version 1.651.3 and weblogic-deployer-plugin
    • Similar Issues:

      Description

      When using weblogic deployer plugin to deploy ear files build from Jenkins, the following errors are reported from Jenkins Console output:
      [WeblogicDeploymentPlugin] - DEPLOYING ARTIFACT...
      $ C:\APPS\Oracle\Middleware_10.3.6\jdk160_29\jre\bin/java -Xms256M -Xmx256M -cp C:\Oracle\Middleware\Oracle_Home\wlserver\server\lib\wlthint3client.jar weblogic.Deployer -debug -stage -remote -verbose -upload -name jmig.cvwm.webstart -source C:\TEMP\jenkins-windows-builder-1\workspace\cvb-workbench\implementation\dist\jmig.cvwm.webstart.ear -targets AdminServer -adminurl t3://localhost:7001 -user weblogic -password password1 -deploy
      java.lang.RuntimeException: task completed abnormally (exit code = 1)
      at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.deploy(DeploymentTaskServiceImpl.java:240)
      at org.jenkinsci.plugins.deploy.weblogic.task.DeploymentTaskServiceImpl.perform(DeploymentTaskServiceImpl.java:169)
      at org.jenkinsci.plugins.deploy.weblogic.WeblogicDeploymentPlugin.perform(WeblogicDeploymentPlugin.java:304)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:782)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:723)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:668)
      at hudson.model.Run.execute(Run.java:1763)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:410)
      ERROR: [WeblogicDeploymentPlugin] - Failed to deploy.
      [INFO] ------------------------------------------------------------------------
      [INFO] DEPLOYMENT FAILURE
      [INFO] ------------------------------------------------------------------------

      Please note that the slash "/" in the path "C:\APPS\Oracle\Middleware_10.3.6\jdk160_29\jre\bin/java" which causes the failure.

      The following messages are logged in the weblogic deployment logs:
      java.lang.NoClassDefFoundError: weblogic/Deployer
      Caused by: java.lang.ClassNotFoundException: weblogic.Deployer
      at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      Could not find the main class: weblogic.Deployer. Program will exit.
      Exception in thread "main"

        Attachments

          Activity

          raphc Raphael CHAUMIER added a comment - - edited

          Not sure this is the problem. Do you have more detailed logs ?

           

          You are using wlthint3client.jar with weblogic 10.3. Can you try with  wlfullclient.jar?

          raphc Raphael CHAUMIER added a comment -

          Hi Fei Tan

          Having no feedback and as I can't reproduce it, I reject this issue.

          Regards

          raphc Raphael CHAUMIER added a comment -

          No feedback. Cannot reproduce error.


            People

            • Assignee:
              raphc Raphael CHAUMIER
              Reporter:
              feitan1222 Fei Tan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: