Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40689

Java 10 compatibility

    XMLWordPrintable

    Details

    • Epic Name:
      Java 10 compatibility
    • Similar Issues:

      Description

      Currently Jenkins does not support Java 9, but we may want to do it soon. I have created this EPIC to start aggregating issues reported by users.

      Assumed that many of the components in Jenkins will need updates for Java 9 support. For example:

      • ASM 6.0 supports JDK 9 as of 23 Sep 2017
      • Jetty 9.4.8 supports JDK 9 as of 21 Nov 2017 (using ASM 6.0)

      Change sources:

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                oleg_nenashev Oleg Nenashev
              • Votes:
                17 Vote for this issue
                Watchers:
                40 Start watching this issue

                Dates

                • Created:
                  Updated: