Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40705

Multibranch Pipeline fails to index GitHub repos using GitHub readonly credentials

    Details

    • Similar Issues:

      Description

      Multibranch Pipeline fails to index GitHub repos using readonly users without a meaningful/helpful message.

      Started
      Connecting to https://api.github.com using cyrille-leclerc/****** (cyrille-leclerc@github.com read only)
      Looking up my-company/my-repository
      
        Getting remote pull requests...
      
          Checking pull request #14
      FATAL: Failed to recompute children of my-company ยป my-repository
      java.io.FileNotFoundException: {"message":"Not Found","documentation_url":"https://developer.github.com/v3"}
      	at org.kohsuke.github.Requester.handleApiError(Requester.java:592)
      	at org.kohsuke.github.Requester._to(Requester.java:272)
      	at org.kohsuke.github.Requester.to(Requester.java:213)
      	at org.kohsuke.github.GHRepository.getCollaboratorNames(GHRepository.java:478)
      	at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.isTrusted(GitHubSCMSource.java:719)
      	at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.doRetrieve(GitHubSCMSource.java:396)
      	at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.retrieve(GitHubSCMSource.java:365)
      	at jenkins.scm.api.SCMSource.fetch(SCMSource.java:148)
      	at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
      	at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
      	at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
      	at hudson.model.ResourceController.execute(ResourceController.java:98)
      	at hudson.model.Executor.run(Executor.java:404)
      Caused by: java.io.FileNotFoundException: https://api.github.com/repos/my-company/my-repository/collaborators
      	at com.squareup.okhttp.internal.huc.HttpURLConnectionImpl.getInputStream(HttpURLConnectionImpl.java:243)
      	at com.squareup.okhttp.internal.huc.DelegatingHttpsURLConnection.getInputStream(DelegatingHttpsURLConnection.java:210)
      	at com.squareup.okhttp.internal.huc.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:25)
      	at org.kohsuke.github.Requester.parse(Requester.java:524)
      	at org.kohsuke.github.Requester._to(Requester.java:251)
      	... 11 more
      Finished: FAILURE
      

        Attachments

          Issue Links

            Activity

            cleclerc Cyrille Le Clerc created issue -
            cleclerc Cyrille Le Clerc made changes -
            Field Original Value New Value
            Summary Multibranch Pipeline fails to index GitHub repos using readonly users Multibranch Pipeline fails to index GitHub repos using GitHub readonly credentials
            cleclerc Cyrille Le Clerc made changes -
            Description Multibranch Pipeline fails to index GitHub repos using readonly users without a meaningful/helpful message.


            {noformat}
            Started
            Connecting to https://api.github.com using cyrille-leclerc/****** (cyrille-leclerc@github.com read only)
            Looking up my-company/my-repository

              Getting remote pull requests...

                Checking pull request #14
            FATAL: Failed to recompute children of my-company » cloudbees-aws-cli
            java.io.FileNotFoundException: {"message":"Not Found","documentation_url":"https://developer.github.com/v3"}
            at org.kohsuke.github.Requester.handleApiError(Requester.java:592)
            at org.kohsuke.github.Requester._to(Requester.java:272)
            at org.kohsuke.github.Requester.to(Requester.java:213)
            at org.kohsuke.github.GHRepository.getCollaboratorNames(GHRepository.java:478)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.isTrusted(GitHubSCMSource.java:719)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.doRetrieve(GitHubSCMSource.java:396)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.retrieve(GitHubSCMSource.java:365)
            at jenkins.scm.api.SCMSource.fetch(SCMSource.java:148)
            at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
            at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
            at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:404)
            Caused by: java.io.FileNotFoundException: https://api.github.com/repos/my-company/my-repository/collaborators
            at com.squareup.okhttp.internal.huc.HttpURLConnectionImpl.getInputStream(HttpURLConnectionImpl.java:243)
            at com.squareup.okhttp.internal.huc.DelegatingHttpsURLConnection.getInputStream(DelegatingHttpsURLConnection.java:210)
            at com.squareup.okhttp.internal.huc.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:25)
            at org.kohsuke.github.Requester.parse(Requester.java:524)
            at org.kohsuke.github.Requester._to(Requester.java:251)
            ... 11 more
            Finished: FAILURE
            {noformat}
            Multibranch Pipeline fails to index GitHub repos using readonly users without a meaningful/helpful message.


            {noformat}
            Started
            Connecting to https://api.github.com using cyrille-leclerc/****** (cyrille-leclerc@github.com read only)
            Looking up my-company/my-repository

              Getting remote pull requests...

                Checking pull request #14
            FATAL: Failed to recompute children of my-company » my-repository
            java.io.FileNotFoundException: {"message":"Not Found","documentation_url":"https://developer.github.com/v3"}
            at org.kohsuke.github.Requester.handleApiError(Requester.java:592)
            at org.kohsuke.github.Requester._to(Requester.java:272)
            at org.kohsuke.github.Requester.to(Requester.java:213)
            at org.kohsuke.github.GHRepository.getCollaboratorNames(GHRepository.java:478)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.isTrusted(GitHubSCMSource.java:719)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.doRetrieve(GitHubSCMSource.java:396)
            at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.retrieve(GitHubSCMSource.java:365)
            at jenkins.scm.api.SCMSource.fetch(SCMSource.java:148)
            at jenkins.branch.MultiBranchProject.computeChildren(MultiBranchProject.java:294)
            at com.cloudbees.hudson.plugins.folder.computed.ComputedFolder.updateChildren(ComputedFolder.java:157)
            at com.cloudbees.hudson.plugins.folder.computed.FolderComputation.run(FolderComputation.java:122)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:404)
            Caused by: java.io.FileNotFoundException: https://api.github.com/repos/my-company/my-repository/collaborators
            at com.squareup.okhttp.internal.huc.HttpURLConnectionImpl.getInputStream(HttpURLConnectionImpl.java:243)
            at com.squareup.okhttp.internal.huc.DelegatingHttpsURLConnection.getInputStream(DelegatingHttpsURLConnection.java:210)
            at com.squareup.okhttp.internal.huc.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:25)
            at org.kohsuke.github.Requester.parse(Requester.java:524)
            at org.kohsuke.github.Requester._to(Requester.java:251)
            ... 11 more
            Finished: FAILURE
            {noformat}
            recampbell Ryan Campbell made changes -
            Component/s github-branch-source-plugin [ 20858 ]
            Component/s workflow-multibranch-plugin [ 21465 ]
            recampbell Ryan Campbell added a comment -

            Jesse says this is best addressed with his WIP PR for JENKINS-36240.

            recampbell Ryan Campbell made changes -
            Link This issue duplicates JENKINS-36240 [ JENKINS-36240 ]
            stephenconnolly Stephen Connolly added a comment -

            Cyrille Le Clerc is this still an issue with the -SNAPSHOT on JENKINS-36121?

            stephenconnolly Stephen Connolly made changes -
            Labels scm-api-tidy-scrub
            cleclerc Cyrille Le Clerc made changes -
            Link This issue is related to JENKINS-43996 [ JENKINS-43996 ]
            cleclerc Cyrille Le Clerc added a comment -

            Problem seem to be fixed but we still have a noisy message. See JENKINS-43996

            cleclerc Cyrille Le Clerc made changes -
            Status Open [ 1 ] Closed [ 6 ]
            Resolution Fixed [ 1 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-1781 (Web Link)" [ 18577 ]

              People

              • Assignee:
                Unassigned
                Reporter:
                cleclerc Cyrille Le Clerc
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: