Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-40791

Testing Jenkins Webhook Fails with Null Reference

    Details

    • Type: Bug
    • Status: Open (View Workflow)
    • Priority: Critical
    • Resolution: Unresolved
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      2.19.4
    • Similar Issues:

      Description

      When testing a new Service Hook configuration, the test payload fails with the following response:

      Status Code: 400
      Reason Phrase: Bad Request
      HTTP Version: 1.1
      Headers:
      {
        X-Content-Type-Options: nosniff
        X-Error-Message: Object is null (through reference chain: net.sf.json.JSONObject["team-event"]->net.sf.json.JSONObject["resource"]->net.sf.json.JSONObject["reviewers"]->net.sf.json.JSONArray[0]->net.sf.json.JSONObject["reviewerUrl"]->net.sf.json.JSONNull["empty"])
        Connection: close
        Date: Tue, 03 Jan 2017 23:50:11 GMT
        Server: Jetty(9.2.z-SNAPSHOT)
        Content-Length: 9214
        Content-Type: text/plain; charset=UTF-8
      }
      

        Attachments

          Issue Links

            Activity

            Hide
            fbaeuerle Florian Bäuerle added a comment - - edited

            So this seems to be a recurring problem with Microsoft-hosted TFS (a.k.a VSTS/Azure DevOps).

            This partly also is a problem of the (bundled) Jackson ObjectMapper in the bundled tfs-sdk. Apparently it just fails on nulls and I did not find a way to change that behavior.

            for reference: https://developercommunity.visualstudio.com/content/problem/393652/service-hook-jenkins-service-request-body-malforme.html

            Show
            fbaeuerle Florian Bäuerle added a comment - - edited So this seems to be a recurring problem with Microsoft-hosted TFS (a.k.a VSTS/Azure DevOps). This partly also is a problem of the (bundled) Jackson ObjectMapper in the bundled tfs-sdk. Apparently it just fails on nulls and I did not find a way to change that behavior. for reference: https://developercommunity.visualstudio.com/content/problem/393652/service-hook-jenkins-service-request-body-malforme.html
            Hide
            nicolela Nicole Haugen added a comment -

            Note that I have seen this specifically when selecting "Pull request merge attempted" as the trigger type. 

            Show
            nicolela Nicole Haugen added a comment - Note that I have seen this specifically when selecting "Pull request merge attempted" as the trigger type. 
            Hide
            nerumo Marco Bachmann added a comment -

            I'm having the same issue on my VSTS account. I just updated to all the latest versions of all plugins and jenkins itself

            Show
            nerumo Marco Bachmann added a comment - I'm having the same issue on my VSTS account. I just updated to all the latest versions of all plugins and jenkins itself

              People

              • Assignee:
                redsolo redsolo
                Reporter:
                aesanch2 Anthony Sanchez
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: