Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41244

NoSuchMethodError when using with Git 3.0.0 or 3.0.1

    Details

    • Similar Issues:

      Description

      The fix for JENKINS-39837 requires either:

      • Git 2.6.x versions >= 2.6.2 < 3.0.0 ; or
      • Git 3.0.x versions >= 3.0.2

      Thus the minimum Git version is 2.6.2

      This can still let a user have Git 3.0.0 and not get an automatic upgrade.

      In such situations the user will see

      SEVERE: Executor threw an exception
      java.lang.NoSuchMethodError: hudson.plugins.git.GitSCM.setBrowser(Lhudson/plugins/git/browser/GitRepositoryBrowser;)V
      	at org.jenkinsci.plugins.github_branch_source.GitHubSCMSource.build(GitHubSCMSource.java:818)
      	at jenkins.scm.api.SCMSource.build(SCMSource.java:778)
      	at jenkins.branch.MultiBranchProject.newBranch(MultiBranchProject.java:400)
      

      We should be defensive and just alert the user to the problem rather than blow up

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                stephenconnolly Stephen Connolly
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: