Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41451

git-plugin: user accounts are looked up by their name

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: git-plugin
    • Labels:
    • Environment:
      CentOS Linux release 7.2.1511 (Core)
      Jenkins ver. 2.19.1
      git-plugin ver. 2.4.2
    • Similar Issues:

      Description

      Hi Junghun Kim,

      Sorry you're not getting your email, and thank you for the detailed information! It was very helpful in tracking down this issue.

      It looks like the problem is a bug in the Jenkins git-plugin[1] whereby when looking up email addresses, user accounts are looked up by their name, and as there are two users with the name 'Junghun Kim', the other's email is returned.

      Just to confirm, one of these accounts/emails belongs to a separate user? If the email does belong to you, we should be able to disable the other account.

      If not, I'm not sure how to proceed. I'll need to think a little harder about how we might fix this.

      Regards,
      Trevor Bramwell

      [1] https://issues.jenkins-ci.org/browse/JENKINS-9016

      On Wed Oct 26 03:44:00 2016, jhun1105.kim@samsung.com wrote:
      > Hi,
      >
      > I'm iotivity developer.
      >
      > When i push some commit into iotivity, jenkins build system send build
      > infomation mail to another people.
      >
      > So i can't receive it.
      >
      > For example, https://gerrit.iotivity.org/gerrit/#/c/13655/ in this commit,
      >
      > jenkins-daemon@iotivity.org (jenkins-daemon@iotivity.org) sent
      > mail("Build failed in Jenkins: iotivity-verify-tizen #5066") to "
      > junghun0.kim@samsung.com (junghun0.kim@samsung.com)" instead "
      > jhun1105.kim@samsung.com (jhun1105.kim@samsung.com)".
      >
      > I attached my information about iotivity.
      >
      > Please Check it.
      >
      > [IMAGE]
      >
      > [IMAGE]
      >
      > [IMAGE]
      >
      > [IMAGE]
      >
      > Thank you,
      >
      > Junghun Kim.
      >
      >
      > [IMAGE]
      > [IMAGE]
      >

        Attachments

          Issue Links

            Activity

            cjcollier C.J. Collier added a comment -

            This might could be marked as a duplicate of 9016. I'll let triage determine for certain.


              People

              • Assignee:
                Unassigned
                Reporter:
                cjcollier C.J. Collier
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: