Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41502

Show triggers for jobs if upstream job (with link)

    Details

    • Sprint:
      Blue Ocean - 1.1-beta2, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 5
    • Similar Issues:

      Description

      When a pipeline triggers another pipeline, jenkins knows about this.

      This can then be shown in various places as hyperlinks so you can navigate from a downstream job back up stream (see attached screen shot of classic).

      A very useful feature.

        Attachments

          Issue Links

            Activity

            michaelneale Michael Neale created issue -
            michaelneale Michael Neale made changes -
            Field Original Value New Value
            Epic Link JENKINS-35750 [ 171713 ]
            jamesdumay James Dumay made changes -
            Labels pipeline-improvement
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2 [ 296 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.2 [ 296 ] Blue Ocean 1.3 [ 311 ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-41540 [ JENKINS-41540 ]
            jamesdumay James Dumay made changes -
            Status Open [ 1 ] Resolved [ 5 ]
            Resolution Duplicate [ 3 ]
            jamesdumay James Dumay added a comment -

            Splitting the work up to make the cause linkable instead.

            jamesdumay James Dumay made changes -
            Resolution Duplicate [ 3 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean 1.3 [ 311 ] Blue Ocean - 1.1-beta2 [ 306 ]
            Assignee James Dumay [ jamesdumay ]
            jamesdumay James Dumay made changes -
            Link This issue duplicates JENKINS-41540 [ JENKINS-41540 ]
            jamesdumay James Dumay made changes -
            Comment [ Trigger causes are included as part as JENKINS-41540. Please watch for this ticket instead. ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean - 1.1-beta2 [ 306 ] Blue Ocean - 1.1-beta2, Blue Ocean 1.1-beta3 [ 306, 316 ]
            jamesdumay James Dumay made changes -
            Epic Link JENKINS-35750 [ 171713 ] JENKINS-43952 [ 181484 ]
            jamesdumay James Dumay made changes -
            Status Reopened [ 4 ] Open [ 1 ]
            jamesdumay James Dumay made changes -
            Assignee James Dumay [ jamesdumay ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean - 1.1-beta2, Blue Ocean 1.1-beta3 [ 306, 316 ] Blue Ocean - 1.1-beta2, Blue Ocean 1.3 [ 306, 311 ]
            jamesdumay James Dumay added a comment -

            This is waiting on our new extension points to allow this.

            jamesdumay James Dumay made changes -
            Sprint Blue Ocean - 1.1-beta2, Blue Ocean 1.4 [ 306, 311 ] Blue Ocean - 1.1-beta2 [ 306 ]
            jamesdumay James Dumay made changes -
            Rank Ranked higher
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean - 1.1-beta2 [ 306 ] Blue Ocean - 1.1-beta2, Blue Ocean 1.4 - beta 3 [ 306, 416 ]
            Assignee Ivan Meredith [ imeredith ]
            imeredith Ivan Meredith made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            src/main/java/org/jenkinsci/plugins/displayurlapi/ClassicDisplayURLProvider.java
            src/main/java/org/jenkinsci/plugins/displayurlapi/DisplayURLProvider.java
            src/main/java/org/jenkinsci/plugins/displayurlapi/actions/AbstractDisplayAction.java
            src/test/java/org/jenkinsci/plugins/displayurlapi/actions/ActionRedirectExtendedTest.java
            http://jenkins-ci.org/commit/display-url-api-plugin/29162034cbc59d323e87962c8b114f0f083c2e05
            Log:
            {JENKINS-41502] Select provider using a paramater

            imeredith Ivan Meredith added a comment -

            Karl Shultz https://github.com/jenkinsci/display-url-api-plugin/pull/17 is a companion pr, how is testing notes handled in this case?

            kshultz Karl Shultz added a comment - - edited

            Ivan Meredith, you've made it really simple actually, thanks for that. Since the PR has a test included as part of it, I typically do something like this.

            Testing Notes:

            But typically it's not been stories that have received the testing notes, it's been individual issues (bugs, RFEs, etc).

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            src/main/java/org/jenkinsci/plugins/displayurlapi/ClassicDisplayURLProvider.java
            src/main/java/org/jenkinsci/plugins/displayurlapi/DisplayURLProvider.java
            src/main/java/org/jenkinsci/plugins/displayurlapi/actions/AbstractDisplayAction.java
            src/test/java/org/jenkinsci/plugins/displayurlapi/actions/ActionRedirectExtendedTest.java
            http://jenkins-ci.org/commit/display-url-api-plugin/4c68a345a7b691937fe11f40a495461cf23c98ed
            Log:
            Merge pull request #17 from jenkinsci/JENKINS-41502_select_provider_with_parameter

            JENKINS-41502 Select provider using a paramater

            Compare: https://github.com/jenkinsci/display-url-api-plugin/compare/d69340a23e68...4c68a345a7b6

            imeredith Ivan Meredith added a comment -

            Karl Shultz Oh hmm. If we had decent tests in the initial pr's we might not have regressions for testing notes to be generated for!

            kshultz Karl Shultz added a comment -

            Ivan Meredith, That's where we're hoping to get. But testing notes are getting included as part of new/unstarted as well as user-opened issues. In fact, I'd like to start participating in the issue planning process earlier, so that we can do just what you've described - ensure that there are tests included in the initial PRs. We're getting there, it's just not a quick process. There was a lot of catching up to do first.

            I haven't been applying testing notes to the stories mostly because stories tend to be broader in scope, and include >1 issue (task/bug/rfe/etc) in them.

            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal UX-677 (Web Link)" [ 18176 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal UX-677 (Web Link)" [ 18286 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            pom.xml
            http://jenkins-ci.org/commit/blueocean-display-url-plugin/a5eff368714dc20ab2cf094397c942a0e11b9b67
            Log:
            JENKINS-41502 Bump display-url-version

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Ivan Meredith
            Path:
            pom.xml
            src/main/java/org/jenkinsci/plugins/blueoceandisplayurl/BlueOceanDisplayURLImpl.java
            http://jenkins-ci.org/commit/blueocean-display-url-plugin/42785e42fabb84a488a583b013bc41dd9a9ee1f4
            Log:
            JENKINS-41502 Bump display-url version (#12)

            imeredith Ivan Meredith made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal UX-677 (Web Link)" [ 18286 ]
            jamesdumay James Dumay made changes -
            Sprint Blue Ocean - 1.1-beta2, Blue Ocean 1.4 - beta 3 [ 306, 416 ] Blue Ocean - 1.1-beta2, Blue Ocean 1.4 - beta 3, Blue Ocean 1.4 - beta 5 [ 306, 416, 451 ]
            imeredith Ivan Meredith made changes -
            Status In Review [ 10005 ] Resolved [ 5 ]
            Resolution Fixed [ 1 ]

              People

              • Assignee:
                imeredith Ivan Meredith
                Reporter:
                michaelneale Michael Neale
              • Votes:
                1 Vote for this issue
                Watchers:
                8 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: