Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41504

Jenkins integration in CentOs problem

    Details

    • Epic Link:
    • Similar Issues:

      Description

      Hi Team,
      I'm new to Jenkins and i have installed GIT & Jenkins on same machine (Centos) and created sample project in jenkins dashboard.

      when i input GIT URL for a project i'm facing below error

      Failed to connect to repository : Error performing command: ls-remote -h git@192.168.10.124:PRODUCT_IMPORT HEAD.

      Note: I have created a Key without password and its updated in GIT Server. both Jenkins & GIT are available in same server.

        Attachments

          Activity

          Hide
          markewaite Mark Waite added a comment - - edited

          Please use the jenkins-user mailing list for configuration help, rather than a bug report. Far more users read the jenkins user mailing list than read individual bug reports, so you're more likely to receive timely help.

          Though, based on the message, you likely have a system configuration error. The global settings for the git plugin include a location to define the git executable. On a CentOS machine (and almost every other case), it should have the value "git". It appears from your output that the value is empty.

          If it had not been empty, the error message would have been:

          Error performing command: git ls-remote ...

          Instead, you have the error message:

          Error performing command: ls-remote ...

          Show
          markewaite Mark Waite added a comment - - edited Please use the jenkins-user mailing list for configuration help, rather than a bug report. Far more users read the jenkins user mailing list than read individual bug reports, so you're more likely to receive timely help. Though, based on the message, you likely have a system configuration error. The global settings for the git plugin include a location to define the git executable. On a CentOS machine (and almost every other case), it should have the value "git". It appears from your output that the value is empty. If it had not been empty, the error message would have been: Error performing command: git ls-remote ... Instead, you have the error message: Error performing command: ls-remote ...

            People

            • Assignee:
              Unassigned
              Reporter:
              mahen025 Mahendiran Thangavel
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: