Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41653

Support core warning when collecting data

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: support-core-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.32.2 / Windows 2008 / JDK 8 latest
    • Similar Issues:

      Description

      Even if I remove the GC collect from the support page, this event still occurs in logs.
      Tks,

      ./Frederic

      WARNING: [Support Bundle] null does not exist, cannot collect gc logging files.
       ERROR: 'Character reference "&#'
       Feb 02, 2017 10:32:22 AM com.cloudbees.jenkins.support.configfiles.OtherConfigFilesComponent addContents
       WARNING: could not add the audit-trail.xml configuration file to the support bundle because of: javax.xml.transform.TransformerException: org.xml.sax.SAXParseException; lineNumber: 45; columnNumber: 3180; Character reference "&#
      

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Emilio Escobar
            Path:
            src/main/java/com/cloudbees/jenkins/support/configfiles/SecretHandler.java
            http://jenkins-ci.org/commit/support-core-plugin/484b700e203ef1cafcc26b8696de92e92f9f3bfa
            Log:
            JENKINS-41653 static pattern compilation

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Emilio Escobar
            Path:
            src/main/java/com/cloudbees/jenkins/support/configfiles/SecretHandler.java
            http://jenkins-ci.org/commit/support-core-plugin/653b6c76774250533b4fade34a86b4c4e501908c
            Log:
            JENKINS-41653 better safe than sorry

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Baptiste Mathus
            Path:
            src/main/java/com/cloudbees/jenkins/support/configfiles/SecretHandler.java
            src/test/java/com/cloudbees/jenkins/support/configfiles/SecretHandlerTest.java
            http://jenkins-ci.org/commit/support-core-plugin/ef1f4092bda8cf4fd4cbe22dd34c77cbd91a287c
            Log:
            Merge pull request #120 from escoem/JENKINS-41653

            JENKINS-41653 Support core warning when collecting data

            Compare: https://github.com/jenkinsci/support-core-plugin/compare/eabbb45750fc...ef1f4092bda8

            escoem Emilio Escobar added a comment -

            released as 2.43

            jglick Jesse Glick added a comment -

            FTR, observed in 2.41:

            …	WARNING	c.c.j.support.SupportPlugin#writeBundle: Could not attach 'jenkins-root-configuration-files/….xml' to support bundle
            javax.xml.transform.TransformerException: java.lang.ArrayIndexOutOfBoundsException
            	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:746)
            	at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:351)
            	at com.cloudbees.jenkins.support.configfiles.SecretHandler.findSecrets(SecretHandler.java:87)
            	at com.cloudbees.jenkins.support.configfiles.XmlRedactedSecretFileContent.getInputStream(XmlRedactedSecretFileContent.java:21)
            	at com.cloudbees.jenkins.support.api.FileContent.writeTo(FileContent.java:63)
            	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:359)
            	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:273)
            	at com.cloudbees.jenkins.support.SupportPlugin$PeriodicWorkImpl$1.run(SupportPlugin.java:761)
            	at java.lang.Thread.run(Thread.java:748)
            Caused by: java.lang.ArrayIndexOutOfBoundsException
            ---------
            java.lang.ArrayIndexOutOfBoundsException
            Caused: java.io.IOException
            	at com.cloudbees.jenkins.support.configfiles.XmlRedactedSecretFileContent.getInputStream(XmlRedactedSecretFileContent.java:23)
            	at com.cloudbees.jenkins.support.api.FileContent.writeTo(FileContent.java:63)
            	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:359)
            	at com.cloudbees.jenkins.support.SupportPlugin.writeBundle(SupportPlugin.java:273)
            	at com.cloudbees.jenkins.support.SupportPlugin$PeriodicWorkImpl$1.run(SupportPlugin.java:761)
            	at java.lang.Thread.run(Thread.java:748)
            

              People

              • Assignee:
                escoem Emilio Escobar
                Reporter:
                fredericmeyrou Frédéric Meyrou
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: