Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41775

Build Queue is cleared after restart

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Environment:
    • Similar Issues:

      Description

      When restarting jenkins jenkins, all build are removed from the build queue when the restart is complete. Steps to replicate:

      1. Create a Freestyle Job with no additional configuration
      2. Post to the build url with lare delay (eg ?build=10000sec)
      3. Navigate to the /safeRestart url and reboot jenkins

      The end result is that the build is missing from the buildQueue. I have tested this on Ubuntu 16.04 with the same oracle version of java and the builds are present after restart. It appears the issue only affects windows.

        Attachments

          Issue Links

            Activity

            kman1523 Kyle Brennan added a comment -

            It seems that there is now queue.xml file present in the jenkins home directory. Also when posting to the jenkins /exit link, the queue.xml file is successfully generated and the jobs are reloaded.

            kman1523 Kyle Brennan added a comment -

            Seems to be a duplicate of JENKINS-32820, which still is not resolved.


              People

              • Assignee:
                Unassigned
                Reporter:
                kman1523 Kyle Brennan
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: