Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4177

Failing tests do not make a build unstable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Component/s: maven-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      My Maven2 projects are not being made unstable even though the project description
      page says there are test failures. The project is set to use a local maven
      repository. Hudson version is 1.318

        Attachments

          Issue Links

            Activity

            agenticarus agenticarus added a comment -

            Created an attachment (id=823)
            Screenshot of project description page

            agenticarus agenticarus added a comment -

            This is still happening in hudson 1.319. From conversation on IRC with
            'calculus':

            "ok, I worked it out, nothing to do with findbugs... it has to do with multiple
            Maven goals and Hudson only paying attention to the results of the last one"

            "you had mvn -U clean deploy (test runs before deploy) and assuming deploy was
            successful, hudson 1.318 will report a blue/green ball even if tests failed"

            "I have mvn clean test findbugs:findbugs and since the findbugs part is
            successful, hudson reports a blue/green ball even though I had test failures"

            "hudson 1.317 reports a yellow (unstable) ball with test failures and findbugs
            while hudson 1.318 reports a blue ball with test failures and findbugs being
            successful"

            abayer Andrew Bayer added a comment -

            Do you have the incremental builds option on?

            abayer Andrew Bayer added a comment -
                • Issue 4188 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment -

            Ok, I've duplicated this locally.

            abayer Andrew Bayer added a comment -

            Interestingly, I did not get this error when running Hudson 1.317 but with the
            1.318 Maven plugin - so it looks like it may be a change in Hudson core from
            1.317->1.318 that's the culprit.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/main/core/src/main/java/hudson/model/Run.java
            trunk/hudson/main/test/src/test/java/hudson/maven/MavenBuildTest.java
            trunk/hudson/main/test/src/test/resources/hudson/maven/maven-test-failure-findbugs.zip
            http://fisheye4.cenqua.com/changelog/hudson/?cs=20654
            Log:
            [FIXED JENKINS-4177] getResult() is null by default again - no actual live code depended on it being set, as it turned out. Also added integration test for this use case.

            abayer Andrew Bayer added a comment -

            Regrettably, I got this fix in about two hours too late to make it into 1.320,
            but it'll be in 1.321.


              People

              • Assignee:
                abayer Andrew Bayer
                Reporter:
                agenticarus agenticarus
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: