Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41866

Robot Framework creates artifacts owned by root user

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: robot-plugin
    • Labels:
      None
    • Environment:
      Robot Framework plugin 1.6.4
      Workspace Cleanup Plugin 0.32
    • Similar Issues:

      Description

      Robot Framework plugin creates output files with root ownership.

      Because of this, the Workspace Cleanup Plugin is unable to clean up the workspace after a build is done.

      I think the Robot Framework plugin should only create artifacts owned by the user that Jenkins runs as, or it should allow the user to be specified in the configuration.

        Attachments

          Activity

          aleksisimell Aleksi Simell added a comment -

          Can you verify that those permissions do come from the plugin? i.e. if you run the job without post-build action, are the log files still with permission 777?

           

          Output.xml, report.html, and log.html are created by RF, not this plugin.

          ssbarnea Sorin Sbarnea added a comment -

          This is clearly not a bug and a local configuration mistake on you Jenkins. Jenkins user should never be able to gain root access, or to create files owned by other user, and on correctly configured system it does not.


            People

            • Assignee:
              jpiironen jpiironen
              Reporter:
              mksmith Matthew Smith
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: