Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4249

HudsonTestCase leaves temporary directories

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      When running tests individually (as "mvn -Dtest=SomeTest test") in
      main/hudson/test, I'm seeing the temporary directories for the Maven install,
      Hudson home, etc, in /tmp sticking around after the test finishes. I can't
      confirm whether they're left there by running the full test suite at the moment,
      but they're definitely still there after individual test classes are invoked
      directly.

        Attachments

          Issue Links

            Activity

            abayer Andrew Bayer added a comment -

            Marking as duplicate of 4409, because Erik's got steps to reproduce in his. =)

                • This issue has been marked as a duplicate of 4409 ***

              People

              • Assignee:
                Unassigned
                Reporter:
                abayer Andrew Bayer
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: