Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42544

com.hp.application.automation.tools.common.SSEException when launching a test

    Details

    • Similar Issues:

      Description

      sometimes, our jenkins instance brecome unavailable to lanch alm tests:

      wher have this error:

      Failed login to ALM Server URL: http://xxx:8080/qcbin. Exception: com.hp.application.automation.tools.common.SSEException: java.lang.StringIndexOutOfBoundsException: String index out of range: -1

      to resolve this problem, whe have to restart the jenkins master

        Attachments

          Activity

          raphael_unique Raphaël UNIQUE created issue -
          yafim_kazak Yafim Kazak made changes -
          Field Original Value New Value
          Assignee Ofir Shaked [ ofirshaked ] Roy Lu [ roy_lu ]
          roy_lu Roy Lu added a comment -

          Hi Raphaël UNIQUE,

          1. What do you mean sometimes? Does the error always happen?
          2. When it happens, can you confirm that the ALM server can be visited?
          3. Can you provide the full error message which has the stack trace?

          I believe it's because the server is down when you're trying to execute a test through Jenkins. If it's true, then we need to make our error message more clear.

          raphael_unique Raphaël UNIQUE added a comment -

          Hello Roy,

          1) not always. it can works for many days, and suddenly become KO and then the error occurs for any job until the jenkins master is restarted

          2) yes, i can confirm the ALM server can be visited.

          3) i have nothing else in the jenkins log:

          Failed login to ALM Server URL: http://alm.stef.com:8080/qcbin. Exception: com.hp.application.automation.tools.common.SSEException: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
          Empty Results
          Result Status: UNSTABLE
          roy_lu Roy Lu added a comment -

          Well Raphaël UNIQUE,

          It is strange for it's not always happens and need a Jenkins restart. I suggest you to commit a ALM CPE ticket, because I think they may need to contact you directly. Something happens on your side need to have a session to investigate. It can't be solved here by just some comments.

          roy_lu Roy Lu added a comment -

          Oh have you tried the latest version of the plugin?

          yafim_kazak Yafim Kazak made changes -
          Labels ALM
          raphael_unique Raphaël UNIQUE added a comment - - edited

          no, i can't upgrade to 5.1 version because of the issue JENKINS-33433

          we had to roolback to version 5.0 of the plugin

           

          the JENKINS-42544 issue still occured 2 days ago

          roy_lu Roy Lu added a comment -

          Can you check that if the issue occure, visit 
          http://alm.stef.com:8080/qcbin/rest/is-authenticated
          what headers and values would you get in the response?

          raphael_unique Raphaël UNIQUE added a comment - - edited

          the error occured yesterday:

          • http://alm.stef.com:8080/qcbin/rest/is-authenticated
            
            Error 401 Authentication failed. Browser based integrations - to login append '?login-form-required=y' to the url you tried to access.
            h2. HTTP ERROR 401
            
            Problem accessing /qcbin/rest/is-authenticated. Reason:
            
            Authentication failed. Browser based integrations - to login append '?login-form-required=y' to the url you tried to access.
            
             
            ----
            Powered by Jetty://
             

          Headers:

          Cache-Control →must-revalidate,no-cache,no-store
          Content-Length →541
          Content-Type →text/html; charset=ISO-8859-1
          Date →Wed, 28 Jun 2017 08:13:03 GMT
          Server →Jetty(9.1.4.v20140401)
          WWW-Authenticate →LWSSO realm="http://alm.stef.com:8080/qcbin/authentication-point"
          
          roy_lu Roy Lu added a comment -

          Hi Raphaël UNIQUE,

          The response seems ok. I suggest you to submit a ALM case, a private channel. Because this problem need further investigation.  Something may not proper to communicate here in a public place.

          Since it not always happens. I guess it's because of network problem or ALM down.

          roy_lu Roy Lu made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Done [ 10000 ]
          guevara tarik MBARKI added a comment -

          Salut Raphaël, 

          I think the problem come from the version of parametrized-remote-trigger-plugin plugin, the value of cookie is setting statically.

          Check you  parametrized-remote-trigger-plugin version, it should not be (3.0.0 ~ 3.0.4)

          raphael_unique Raphaël UNIQUE added a comment -

          Hi Tarik,

           

          version deployed: 3.0.6


            People

            • Assignee:
              roy_lu Roy Lu
              Reporter:
              raphael_unique Raphaël UNIQUE
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: