Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42564

App cannot be copy to Jenkins Master in HockeyApp 1.2.2 (Error: java.lang.NullPointerException)

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Fix
    • Component/s: hockeyapp-plugin
    • Labels:
    • Environment:
      Jenkins: 2.32.3 LTS
      HockeyApp: 1.2.2
    • Similar Issues:

      Description

      Jenkins Master: # of executors: 0

      Build app succeed and also can be archived. The HockeyApp Path:

      App File (.ipa, .app.zip, .apk)app/build/outputs/apk/xxx-${BUILD_NUMBER}-${BuildType}.apk

      Upload Error:

      Uploading to HockeyApp...
      /tmp/jtf7699425629259393086.tmp/xxx-14-debug.apk
      java.lang.NullPointerException
      at java.util.concurrent.ConcurrentHashMap.putVal(ConcurrentHashMap.java:1011)
      at java.util.concurrent.ConcurrentHashMap.put(ConcurrentHashMap.java:1006)
      at org.apache.http.impl.client.BasicCredentialsProvider.setCredentials(BasicCredentialsProvider.java:61)
      at hockeyapp.HockeyappRecorder.createPreconfiguredHttpClient(HockeyappRecorder.java:165)
      at hockeyapp.HockeyappRecorder.performForApplication(HockeyappRecorder.java:252)
      at hockeyapp.HockeyappRecorder.perform(HockeyappRecorder.java:204)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      at hudson.model.Run.execute(Run.java:1753)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:404)

       

      I've checked the Jenkins Master, and there's no folder like /tmp/jtf*.tmp folder

      But When I downgrade the HockeyApp plugin to 1.2.1, the application can be uploaded succeed with the exact same configuration. And the file can be found at JenkinsMarslo: /tmp/jft*._tmp folder also.

       

      ---

      The second attempted:

      Change the App File (.ipa, .app.zip, .apk)*/*/xxx-17-${BUILD_TYPE}.apk

      Error:

      Uploading to HockeyApp...
      No IPA/APK found to upload in: */*/xxx-17-${BUILD_TYPE}.apk

       

      The third attempted:

      Change the _App File (.ipa, .app.zip, .apk): ${WORKSPACE}/app/build/outputs/apk/xxx-${BUILD_NUMBER}-${BuildType}.apk_

      Error:

      Uploading to HockeyApp...
      java.io.IOException: remote file operation failed: /home/salve/workspace/xxxx-job at hudson.remoting.Channel@b31cdf8:slave: java.io.IOException: Expecting Ant GLOB pattern, but saw '/home/slave/workspace/xxxx-job/app/build/outputs/apk/xxx-13-debug.apk'. See http://ant.apache.org/manual/Types/fileset.html for syntax
      at hudson.FilePath.act(FilePath.java:992)
      at hudson.FilePath.act(FilePath.java:974)
      at hudson.FilePath.list(FilePath.java:1719)
      at hudson.FilePath.list(FilePath.java:1704)
      at hudson.FilePath.list(FilePath.java:1690)
      at hockeyapp.HockeyappRecorder.performForApplication(HockeyappRecorder.java:226)
      at hockeyapp.HockeyappRecorder.perform(HockeyappRecorder.java:204)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:665)
      at hudson.model.Run.execute(Run.java:1753)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:404)
      Caused by: java.io.IOException: Expecting Ant GLOB pattern, but saw '/home/appadmin/workspace/COPD_Android/app/build/outputs/apk/Copd-13-debug.apk'. See http://ant.apache.org/manual/Types/fileset.html for syntax
      at hudson.FilePath.glob(FilePath.java:1741)
      at hudson.FilePath.access$1700(FilePath.java:195)
      at hudson.FilePath$32.invoke(FilePath.java:1722)
      at hudson.FilePath$32.invoke(FilePath.java:1719)
      at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2731)
      at hudson.remoting.UserRequest.perform(UserRequest.java:153)
      at hudson.remoting.UserRequest.perform(UserRequest.java:50)
      at hudson.remoting.Request$2.run(Request.java:336)
      at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      at java.lang.Thread.run(Thread.java:745)
      at ......remote call to slave01(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1537)
      at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
      at hudson.remoting.Channel.call(Channel.java:822)
      at hudson.FilePath.act(FilePath.java:985)
      ... 15 more

        Attachments

          Issue Links

            Activity

            ravikiran082 Ravikiran Annavarapu added a comment -

            Today I tried to upload IPA build via HockeyApp plugin in Jenkins.. I configured new app in HockeyApp site and all configuration settings are fine..But when I given my IPA build path, it was throwing error like" Expecting Ant GLOB pattern, but saw "..Can anyone suggest any fix for this

            marslo Marslo Jiao added a comment -

            Hi Ravikiran Annavarapu, I'm using the Hockyapp 1.2.1, and it works.

            mezpahlan Mez Pahlan added a comment -

            As per this discussion I don't think you can use absolute paths in the Ant GLOB pattern. Can you please try this again with a relative path to the Jenkins workspace.

            mezpahlan Mez Pahlan added a comment -

            Appears to be an issue with how the path is specified by the end user. GLOB patterns aren't absolute but relative to the workspace.


              People

              • Assignee:
                mezpahlan Mez Pahlan
                Reporter:
                marslo Marslo Jiao
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: