Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.32.3, warnings plugin 4.60
    • Similar Issues:

      Description

      I have a pipeline job where the warnings are displayed only sometimes. When building a new commit, they are there. Rebuilding that commit shows the warnings, until it doesn't anymore. Rebuilding after that doesn't bring them back in the report (of course they are present in the log). If it should matter, it is with the Erlang parser.

        Attachments

          Issue Links

            Activity

            Hide
            vladdu Vlad Dumitrescu added a comment - - edited

            Oops, exactly when I said that I got a "no warnings" run... So a three seconds delay doesn't help.

            Show
            vladdu Vlad Dumitrescu added a comment - - edited Oops, exactly when I said that I got a "no warnings" run... So a three seconds delay doesn't help.
            Hide
            drulli Ulli Hafner added a comment - - edited

            Are the messages the same for the working builds? The warnings plugin should report a line that shows the actual number of warnings...

            Show
            drulli Ulli Hafner added a comment - - edited Are the messages the same for the working builds? The warnings plugin should report a line that shows the actual number of warnings...
            Hide
            vladdu Vlad Dumitrescu added a comment -

            The logs are exactly the same. No summary (and I can't see one in other jobs either).

            Show
            vladdu Vlad Dumitrescu added a comment - The logs are exactly the same. No summary (and I can't see one in other jobs either).
            Hide
            vladdu Vlad Dumitrescu added a comment -

            I think there was an issue on my side, it works now with the `sleep` workaround, so it is a duplicate of  JENKINS-32191. Thanks!

            Show
            vladdu Vlad Dumitrescu added a comment - I think there was an issue on my side, it works now with the `sleep` workaround, so it is a duplicate of  JENKINS-32191 . Thanks!
            Hide
            drulli Ulli Hafner added a comment -

            Ok, then please vote for the other issue to get it fixed as soon as possible

            Show
            drulli Ulli Hafner added a comment - Ok, then please vote for the other issue to get it fixed as soon as possible

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                vladdu Vlad Dumitrescu
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: