Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-42680

Creating a Folder as a child of ComputedFolder causes Jenkins to hang

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Latest version of the folders plugin on a clean Jenkins 2.7.1
    • Similar Issues:

      Description

      In writing my own ComputedFolder any attempts to create a Folder as a child during computeChildren results in the folder being physically written to disk but maxing multiple CPU cores and hanging Jenkins. This issue persists through Jenkins restarts and any Job created with this structure causes the same issue. It does not hang Jenkins until the Job is navigated to on reboot.

      A simple test case of this can be done by extending ComputedFolder, creating a Folder (with the computed as it parent) and using the observer methods to register it. Manually using itemsPut also causes the same issue - Jenkins will hang if you try to navigate to view that folder.

        Attachments

          Issue Links

            Activity

            egutierrez Evaristo Gutierrez added a comment - - edited

            I have raised a PR including an automated test which reproduces this issue.

            This happens also for 5.13 and 5.17 versions.

            stephenconnolly Stephen Connolly added a comment -

            Which seems somewhat strange as this is exactly what OrganizationFolder does...

            stephenconnolly Stephen Connolly added a comment -

            So the issue is when there is any Folder that is a child of any AbstractFolder subclass that is not a Folder subclass (which explains how OrganizationFolder was OK, because all its children are not Folder subclasses)

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            src/main/java/com/cloudbees/hudson/plugins/folder/relocate/StandardHandler.java
            http://jenkins-ci.org/commit/cloudbees-folder-plugin/22f56ef80880c0b79842bcd5cb480c84fa27f6f4
            Log:
            [FIXED JENKINS-42680] Prevent infinite loop when a Folder is a child of an AbstractFolder

            Carbon Kieran Webber added a comment -

            Issue fixed in linked PR in 6.0.3


              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                Carbon Kieran Webber
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: